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Overview 
This document lists and describes the different rights that can be set in the 
Central Management Console (CMC) and their impact on the different 
applications.  
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Introduction 
The BusinessObjects XI Release 2 security model is based on rights and the 
Access Control List, which is a collection of rights and specific states (Explicitly 
Granted, Explicitly Denied or Not Specified) for those rights. This Access 
Control List defines for a principal (a user or a group) what operations this 
principal is allowed to perform. In BusinessObjects XI Release 2, this model is 
very powerful since:  

• It is generic and the same framework is used for all objects that are stored 
in the BusinessObjects repository: users, groups, folders, documents, 
universes, servers, categories… 

• Rights can be inherited both from folders to objects and from users to 
groups. This provides administrators a very flexible framework to design 
security  

• The model is very granular and rights can be set at different levels  

Nevertheless, to fully benefit from this security model, it is mandatory to 
understand the meaning and impact of each right and their relationships. 

This document lists and describes the different rights that can be set in the 
Central Management Console (CMC) and their impact on the different 
applications.  

It does not describe in detail the BusinessObjects XI Release 2 security model 
(see BusinessObjects Enterprise XI Release 2 Administrator’s Guide). It does 
not cover universe restriction sets that can be defined in the Universe Designer 
(see BusinessObjects Enterprise XI Release 2 Designer’s Guide). 

This document refers to BusinessObjects XI Release 2 SP2 but should be 
compliant to some extent to most BusinessObjects XI Release 2 versions. 

NOTE In the remainder of this document:  

• Disabled means that the label, menu, button, is displayed but it is unavailable and 
cannot be modified, activated or clicked.  

• Not displayed means that it does not appear at all in the User Interface.  

Overview 

General Compared to Custom Rights 
The BusinessObjects Enterprise system defines a set of General rights that 
apply to all objects in the system. For example, the View objects right is a 
General right as it applies equally well to folders, reports, and other 
BusinessObjects Enterprise objects like users or groups.  

NOTE A user or a group is an object in BusinessObjects Central Management Server (CMS) and 
therefore it has a set of rights that can be applied to it. 
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In addition to these base rights, however, each type of object provides an 
additional set of rights that apply only to that object type. For example, the 
Refresh the report’s data right applies only to report objects. 

The CMS is the component that keeps track of available rights. The list of 
available rights includes the base rights and all other object-specific rights that 
have been provided by particular object types, such as Crystal Reports objects. 

In the CMC, on the Advanced Rights pages you will find that all of the 
available rights are displayed for every object on the system. These rights are 
grouped based on what type of file they apply to. These groups are General, 
Report, Text, Web Intelligence Document, Desktop Intelligence Document, 
Desktop Intelligence Template and Desktop Intelligence Add-In. When you are 
setting rights for folders, these groups make it easier to see where the rights 
will be applied. For example, the object-specific right Refresh the report’s data 
appears in the report/document specific areas (Web Intelligence Document, 
Desktop Intelligence document and Crystal Reports) because it applies only to 
report objects. 

Available rights are displayed for every object on the system for purposes of 
inheritance, so that you can set object security at the folder level (rather than 
repeating the same settings for every object in the folder). Although certain 
object-specific rights do not strictly apply to the folder object itself, these rights 
may apply to objects that inherit rights from the folder. In other words, the 
Refresh the report’s data right is displayed for the folder object so that you can 
grant a user the right to refresh the data in all reports for which the user 
inherits rights from this folder. 

Modify the Rights Users Have to Objects  
The Modify the rights users have to objects right is a special right that allows 
you to modify any right, for any user on that object.  For example, if you have 
only this right and the View objects right on the object, you can give yourself 
or another user full control over the object by granting all the missing rights. 
The Modify the rights users have to objects right is very powerful, because 
once this right is granted to a user on a particular object, they can grant 
themselves, or anyone else, any right on that object.  

Securely Modify the Rights Users Have to Objects 
The Securely modify the rights users have to objects right is similar but more 
restrictive.  If you have that right on an object, you can grant or deny only the 
rights that you are already granted.  For example, if you have View objects 
and Securely modify the rights users have to objects on an object, you cannot 
give yourself more rights and can give or take away those two rights only.  
Additionally, you can change only rights for users that you have the Securely 
modify the rights users have to objects right set for. 

NOTE This can be used to define a set of users to which a delegated administrator has access. 
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In summary, this right is similar to the Modify the rights users have to objects 
right, but with some restrictions on which rights can be granted, and for which 
users or groups. 

The administrator must also have the apply overload rights granted on the 
universe.  Then, this administrator must be granted Securely modify the 
rights users have to objects on all the users or groups for which he is allowed 
to control rights, but no others.   

NOTE If the administrator is actually in the administrators group, he will by default inherit full 
rights to all users.  To prevent this, you must explicitly add him as a principal at the root 
level user and group folders, and have inheritance turned off there. 

For this reason, it is probably simpler and less chance for error if you start with 
a user who is not in the administrators group. After this is configured, it 
should be possible to modify overloads in the fashion required for 6.x 
compatibility.   

 Modify the rights 
users have to objects 
right = granted 

Modify the rights 
users have to objects 
right  = denied 

Securely modify the rights 
users have to objects right  
= granted 

Granted Granted for the right 
the user is granted 
(see below) 

Securely modify the rights 
users have to objects right 
= denied 

Granted Denied 

 

If a user has the Securely modify the rights users have to objects right 
granted and the Modify the rights users have to objects right denied, then in 
the CMC, in the object’s Advanced Rights pages, this user can only modify the 
rights that are granted to him: 

• The denied rights are disabled and cannot be modified 

• Other rights can be edited and changed to Denied or Inherited. 

Non-Owner and Owner Version of Rights  
Some general rights can exist in two versions: a non-owner version of the right 
(View objects, Edit objects…) and sometime an owner version for the same 
right (View objects that the user owns, Edit objects that the user owns…) 

The owner version of a right is usually named by adding “that the user owns” 
to the name of the non-owner version of the right.  

If the right is the owner version, it applies only if the user owns the object.  
This right is frequently used when many users work in the same area.  
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The following table displays how a right interacts with its owner version and if 
the user is allowed or not to perform the action, depending on the user owner. 

 Owner version of 
the right = 
granted 

Owner version of 
the right = denied 

Object is owned 
by the user  

Granted  Granted Non-
owner 
version of 
the right = 
granted 

Object is not 
owned by the user 

Granted  Granted 

Object is owned 
by the user 

Granted Denied Non-
owner 
version of 
the right = 
denied 

Object is not 
owned by the user 

Denied Denied 

 
For example, you have set the following rights at the folder level for the 
Everyone group with the following values:  

• View objects right: Explicitly Granted 

• Add objects to the folder right: Explicitly Granted 

• Edit objects right: Explicitly Denied 

• Delete objects right: Explicitly Denied 

• Edit objects that the user owns right: Explicitly Granted 

• Edit objects that the user owns right: Explicitly Granted. 

Any user will be able to create a document and add it in the folder. Any user 
will be able to see this document but only the owner will be able to edit or 
delete it. 

NOTE In versions prior to BusinessObjects XI Release 2 SP2, the Edit the objects that the 
user owns right does not work as expected. It has been corrected in BusinessObjects XI 
Release 2 SP2. 

The owner of an object is the user who has created it. If this user is deleted, 
then the object is owned by the Administrator user.  

View Objects Right  
In order to work on an object or to apply an action on it, the View objects right 
is needed. If you have this right denied on an object, you are not able to see or 
access the object. In the remainder of this document, we do not specify that the 
View objects right is mandatory to apply any other action. 
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If the right is denied at a folder level, by inheritance it applies also to the 
objects contained in this folder. Thus, both folder and content are not accessible 
to the user. But if the right has been effectively granted at the object level, you 
can view it, if you have direct access to this object, without having to access it 
through folder navigation.  

NOTE For some objects that can be used by other objects such as universes or connections, if 
their View objects right is set to Denied, then any actions that rely on this object fail. 

Edit Objects Right  
The Edit Objects right is also a general right enforced by the BusinessObjects 
XI Release 2 framework itself. Denying it for an object prevents any change in 
the InfoObject used in the CMS to store this object:  

• The object metadata: name, keywords, description, properties 

• The object itself (Web Intelligence or Desktop Intelligence document, 
universe…) 

• Some links between the objects 

Depending on the client tool, this right can be enforced at different places: 

• The client tool prevents you from making any changes. 

• The client tool lets you make any changes, but the framework returns an 
error message when you try to commit the changes.  

Security and Content Model Design Principles 
The following sections list some principles to follow when designing both 
security and content models. 

Security Model 
Here are some principles to follow when designing security models: 

• The security model should be as simple as possible. It should achieve the 
requirements to secure the content and functionality of the platform, but 
no more.  

• All users on the platform must have their own user identity within the 
platform. There should be no anonymous access. This ensures that the 
platform can be expanded to other applications with different security 
requirements without affecting the current users.  

• The security model should be restrictive by default. That is, access to 
content or functionality is denied by default and must be explicitly 
granted.  

• The granting of rights should be carried out between user groups and 
folders, rather than users and objects, to minimize the administration of 
user management. This should minimize the number of rights assignments 
that need to be set up, and also facilitate the addition of new users to the 
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platform by requiring only that they are added to the appropriate user 
groups to have their rights set.  

• The inheritance of rights from folders to subfolders, from groups to 
subgroups and groups to users should be used wherever possible to 
minimize the total number of rights assignments.  

• An external authentication provider should be used where possible to 
spare the users from having to remember an additional username and 
password for Business Objects Enterprise platform. This also eliminates the 
overhead of having to maintain separate passwords and group 
membership within the Business Objects Enterprise platform.  

• One common security model is to set up two user groups hierarchies 
assigning rights for functionality access and resource access. Thus, by 
adding a user to the appropriate groups, you can define this user security. 

Content Model 
Here are some principles to follow when designing content models: 

• The content model should be as simple as possible to minimize the 
administrative overhead.  

• The folder structure defines the workflow by which users typically locate 
report content, and thus should be aligned, where possible, to how users 
conceptualize the structure of information within your organization.  

• The folder structure should be consistent with any format categorization 
scheme that has been defined for your organization. Its purpose should be 
to categorize the content, rather than to provide some sort of filtering on 
the data.  

• The folder structure that categorizes content should be closely aligned to 
the responsibility for that content. Where possible, the responsibility to 
manage and publish content to a particular folder should be with one 
group only.  

• Each document object should be published once where possible. 
Parameterization and filtering should be uses to allow the same report to 
provide information at multiple levels. Shortcuts can be used to allow the 
same document content to be available from multiple folders where this is 
logical.  

• The depth of the folder hierarchy should be minimal, while still providing 
sufficient categorization to be understandable. The structure should be 
sufficiently granular that the number of subfolders or reports in a folder 
should not be greater than 20.  

• The folder structure should be integrated, and deal with all subject areas 
and applications consistently.  

• The folder hierarchy must be able to deal with the administrative 
considerations, such as supporting multiple environments (for example 
development, test and production). End-users can be isolated from these 
folders by applying security, but they need to be considered in the design.  
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Additional Tips on Using Rights 
Here are some additional tips: 

• Check the aggregation rule. The following table describes rules that apply 
when a right is inherited from two different groups by a user (or a group) 
belonging to these two groups: 

 

Group 1 right  

Explicitly 
Granted 

Explicitly 
Denied 

Not Specified 

Explicitly 
Granted 

Granted Denied Granted 

Explicitly Denied Denied Denied Denied 

Group 2 
right 

Not Specified Granted Denied Not Specified 

These rules are associative and commutative and rights aggregation can be 
extended to more groups.  

• Use Explicitly Denied with care as it is very restrictive, especially if it is set 
to the Everyone group. If a user belonging to a group where this right is 
explicitly denied is added to a group where this right is granted, the 
effective value will remain denied (see above). We recommended you use 
the Not Specified value. The effective value of the right is denied, but it can 
be overridden if the user belongs to a group where this right has been 
Explicitly Granted.  

• No Access can be overridden as it sets the right to Not Specified, whose 
value is denied by default. But if the user or the group explicitly inherits 
Explicitly Granted for this object from another group, then it will grant this 
right, even if No Access has been set somewhere else.  

• Full Control access level can be overridden if you are in a group that also 
belongs to another group where the same right has been explicitly denied. 
The aggregation rule will deny this right to this user.  

• By default, if a right is set to Explicitly Denied at a group level, this right 
will be inherited and set to denied for the groups or users in this group, 
even if it has been set to Explicitly Granted at a lower level. The 
BusinessObjects XI Release 2 framework is restrictive and by default a 
denied right stays denied with inheritance. The only way to workaround 
this behavior is to use the break inheritance option. But this option will 
break inheritance for all rights.  

• Rights can be denied to a user in the Administrators group. To the CMS, 
such user is like any other so the same security model applies to them. 
Thus, a right can be denied to them, preventing them from running some 
actions/tasks.  
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• Rights Values can remain in cache. Most of the time, they are computed in 
real-time unless a session has already been opened. In some 
cases/workflows, the value of the rights may remain in cache even after 
the right has been modified in the CMC. As long as the session remains 
opened. So it is recommended that you consider that the latest value of a 
right is retrieved after a log off. 

Security recommendations 
Here are some recommendations to help secure your system: 

• Change the Administrator’s password, which is blank by default. This 
should be changed to a complex password. The administrator user should 
not be used for day-to-day administrative tasks, so this 
username/password should be kept secure.  

• Disable the Guest account. This account allows anonymous access to the 
platform. This should be disabled to ensure that all users logon using a 
named account. This will allow the auditing to function effectively.  

• Create Platform Administration users. The platform administrators should 
have named users created for each administrator and these users should be 
added to the Administrators group. These users should be used in 
preference to the default Administrator account in order to ensure that 
actions are logged correctly.  

• Remove rights from the Everyone group. By default, it has rights to view 
many of the objects in the system. In order to implement a shared secured 
environment, this group should not be given rights by default, and rights 
should be granted only through group membership. This group should be 
assigned the No Access role in the following areas: 

• At a global level for content objects, by selecting Settings > Rights 
within the CMC. This will set the default rights to No Access for all 
objects within the system.  

• Assign the Everyone group the Inherited Rights role for groups, users, 
server groups, servers, categories, calendars and events. This will 
cause the Everyone group to disappear from the rights list as it 
effectively has no rights by inheritance.  

• Assign the Everyone group the No Access role for universes and 
universe connections.  

• Set the Everyone group to have Not Specified for all advanced rights 
that are denied to regular users for applications such as the CMC, 
Designer, or InfoView.  

• Define Password settings. Passwords policy covers some properties related 
to password: Does the password never expire? Does it have to contain at 
least X number of characters? Define the rules to apply, then set them in 
the CMC, in the Authentication page. 

• The platform does not differentiate upper case and lower cases for user 
and group names. 
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User and Group Rights 
The following table lists the rights that can be set at User and Group level. The 
XI Release 2 framework provides inheritance from group level to user level.  

We are introducing here a concept of user/groups having rights to 
user/groups. In order to better understand the impact of rights we are 
introducing two new terms: master user/group and managed user/group. 

User/group Description 

Master user/group The user/group that will have rights given 
on an object (in this case, the managed 
user/group). 

Managed user/group The user/group that is being managed or 
this is the user/group that master 
user/groups will have certain rights to. 

 
The common misconception is that the Rights tab for a User/Group in the 
CMC controls what that user/group can do to other user/groups. In fact the 
Rights tab on User/Groups controls what other (master) user/groups can do 
to this (managed) user/group. 

If a right is explicitly denied for a group, then it will denied for any user 
belonging to this group, even if this user belongs to other groups where this 
right is granted (except if inheritance is broken). 

The owner of a user or a group is the user that creates this object. This owner is 
used in the owner version of some rights (see Non-Owner and Owner Version 
of Rights  on page 5). 

NOTE Users/groups rights on users/groups is also referred as Delegated Administration. 

 

General Right Description Impact if this right is denied 

Add objects to 
the folder  

Does not have any impact for 
user or group. Adding a 
user/group in another group is 
granted with the Edit objects 
right. 

N/A 
 

View objects* Allows the master user to see a 
group or a user.  

See View objects on page 6. 
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General Right Description Impact if this right is denied 

Edit objects* Allows the master user to edit a 
group or user’s name,  
properties, the groups it 
belongs to and the groups that 
belong to it (groups only). 
To add a managed user/group 
in another group, you need to 
have the Edit objects right 
granted both for the destination 
group and the managed 
user/group. 

Select a group or a user. The content of all their tabs 
except Rights is disabled, text fields cannot be edited 
and buttons cannot be clicked. Especially, the controls 
to add a user or group in another group are disabled:  
• In the Users tab of a group, the Add Users… and 

Remove Users… buttons are disabled.  
• In the Subgroups tab of a group, the 

Add/Remove Subgroups… button is disabled.  
• In the Member of tab of a group or user, click the 

Member of… button. In the Modify Member of 
page, in the lists of groups, this group or user is 
disabled and cannot be added or removed from 
the selection. 

Modify the rights 
users have to 
objects* 

See Modify the rights users 
have to objects on page 4. 

See Modify the rights users have to objects on page 4.  

Delete objects* Allows the master user to 
delete the managed 
group/user. 

In the All Users list, select the check box near this user 
name, click the Delete button; a separate error 
message box appears.  

Change user 
password*    

Allows the master user to 
modify the password of the 
managed user. This right does 
not control the password 
restrictions (Password never 
expires, User must change 
password at next logon, User 
cannot change password), nor 
the Data Source Credentials for 
Business Objects Universes. 

In this user page, in the Properties tab: 
• all content under the Enterprise Password 

Settings, Enable Data Source Credentials for 
Business Objects Universes and Connection Types 
sections are disabled.  

• Click the Update button; an error message is 
displayed. 

Copy objects to 
another folder  

Does not have any impact for 
user or group. Adding a 
user/group in another group is 
controlled through the Edit 
objects right. 

N/A 
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General Right Description Impact if this right is denied 

Schedule to 
destinations    

Allows the master user to add a 
user (for which he has this 
right) onto any publication as a 
recipient. 
The owner version of this right 
is the Subscribe to 
publications the users that the 
user owns right, discussed 
below.  
 

CMC:  
• For a group or a user: For a publication click the 

Schedule tab > Recipients tab > Add button in 
the Subscribed section. Select this user or group 
and click the Update button; an error message is 
displayed.  

• For a user, you have also the same behavior for 
the Add button in the Excluded section. 

InfoView:  
• For a group: click a publication’s Modify link, 

click Add or remove groups if desired… link, 
select this group and add it in the Subscribed 
Groups list. Click OK, click OK; an error message 
is displayed. 

• For a user: click a publication’s Modify link, click 
Add or remove groups if desired… link, select 
this user and add it in the Included Users list. 
Click OK, click OK; an error message is 
displayed. 

Securely modify 
rights users have 
to objects* 

See Securely modify rights 
users have to objects on page 4. 

See Securely modify rights users have to objects on 
page 4. 

Schedule on 
behalf of other 
users*    

N/A N/A 

Subscribe to 
publications the 
users that the 
user owns. 

Allows the master user to add a 
managed user onto any 
publication as recipient if he is 
the owner of this user. This 
right is the owner version of the 
Schedule to destinations right. 

See Schedule to destinations right above. 

* This right exists also in an owner version. See Non-Owner and Owner 
Version of Rights on page 5. 

Category Rights 
Categories come from BusinessObjects Enterprise version 5.x/6.x where 
folders did not exist. In order to be consistent with the version 5.x/6.x 
framework, categories have been implemented in BusinessObjects XI Release 2, 
which also uses folders to organize documents. Categories can contain sub-
categories, but a category can belong to only one category.  

Rights on categories are inherited by categories belonging to this category. 
Nevertheless, these rights are not inherited by documents included in the 
category. 

The folder structure is navigated separately from the category structure. But 
you have to have a right to the object within the folder structure before you can 
see that object in the category structure.  
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On the contrary, if you deny the View objects right on a category, you may 
still view the objects that belong to this category if you have View Objects 
right granted through the folder inheritance.  

For example, if a user has the View objects right denied for a category 
containing a sub-category and a document, he can view the document through 
the folder tree hierarchy but cannot see the category and its subcategory.  

 

Custom Right Description Impact if this right is disabled 

Add objects to 
the folder  

Allows you to: 

• Create a new category in 
this category  

• Move another category into 
this category. You also need 
the rights Delete objects 
and Edit objects granted 
for the category to move 
into this category. 

The right Add objects to the 
folder is not needed to add a 
document into this category. 

InfoView:  

• Select this category in the category tree navigation 
panel. Select New > Category. Enter the new 
category name, click OK; an error message is 
displayed. 

• Click the Show Categories button, select a 
category, click the Move button, select this 
category as a destination, click OK button; an 
error message is displayed.  

CMC:  

Select a category, click the Move button, select this 
category in the list of categories; the OK button is 
disabled. 

View objects* Allows you to see the category 
and the sub-categories it 
contains. 

See View objects on page 6. 
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Custom Right Description Impact if this right is disabled 

Edit objects* Allows you: 

• To modify category 
properties such as name, 
description and keywords 

• To move this category into 
another category. The 
Delete object right must 
also be granted for this 
category and the Add 
objects to the folder right 
must also be granted for the 
destination category. 

• To add a document in this 
category or remove it from 
this category the Edit 
objects right must also be 
granted for the document 
to add to this category. The 
Add object to another 
folder right is not needed 
for this category. 

InfoView:  

• Click the Show Categories button to display the 
categories tree. Select this category: 

• Click the Properties button; the Properties 
page appears but cannot be edited. 

• Click the Move button, select a destination 
category, click the OK button; an error 
message is displayed.  

• Click the document’s Properties link, select this 
category in the Categories section, click the OK 
button; an error message is displayed. 

CMC:  

• In the category’s Properties tab content is 
disabled and cannot be edited. The Update and 
Reset buttons are disabled.  

• In the category’s Objects tab, the Add and 
Exclude buttons are disabled.  

• In a document’s Categories tab, click the Assign 
Categories button. The Assign Corporate (or 
Personal) Categories page appears but this 
category does not appear in the list. 

Modify the rights 
users have to 
objects* 

See Modify the rights users 
have to objects on page 4. 

See Modify the rights users have to objects on page 4. 

Delete objects* Allows you to delete this 
category. 

This right must be also granted 
to move this category into 
another category, in addition of 
the Edit objects right for this 
category and the Add objects 
to the folder for the destination 
category. 

CMC: In the categories list, select this category. Click 
the Delete or Move… button; an error message box 
appears. 

InfoView: Click the Show Categories button to 
display the categories tree, select this category, click 
the Delete or Move… button; a separate error 
message box appears. 

Copy objects to 
another folder     

N/A  N/A 

Securely modify 
rights users have 
to objects*    

See Securely modify rights 
users have to objects on page 4. 

See Securely modify rights users have to objects on 
page 4. 

 
* This right exists also in an owner version. See Non-Owner and Owner 
Version of Rights on page 5. 
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Application Rights 
This section describes the General rights that are common to all applications 
and then describes each application’s custom rights. 

General Rights 
All applications have a minimum of four general rights that define if the user is 
allowed to use the application and administer it in the CMC.  

General  Right Description Impact if this right is denied 

Log on to 
<application 
name> and 
view this object 
in the CMC     

Allows you to log onto 
the application and see 
this application 
property in the CMC. 

CMC: The application is not listed in the application lists. 
In the application itself: In the application logon page or 
window, after entering a valid username and password; an error 
message is displayed. 
If the application is Performance Management: 
• The name of this right is Use Performance Management 

• the icon and link to Performance Management are not 
displayed in InfoView.  

Edit this object    Allows you to modify 
this application’s 
properties in the CMC. 

CMC: All items in the Property tab of the application are 
disabled and cannot be edited. 

Modify the 
rights users 
have to this 
object     

See Modify the rights 
users have to objects on 
page 4. 

See Modify the rights users have to objects on page 4. 

Securely 
modify rights 
users have to 
objects 

See Securely modify 
rights users have to 
objects on page 4. 

See Securely modify rights users have to objects on page 4. 

 
In addition to these four general rights, each application (except the Report 
Conversion Tool and the CMC) has a set of Custom rights that depend on the 
application. Performance Management has different sets of Custom rights. 

NOTE If you are not allowed to connect to an application, before investigating the values of 
some rights, you should check that you have the correct licenses for the application you 
are using. 

 

InfoView Rights  
These rights control some interface items in InfoView, and thus the use of the 
corresponding functionalities. Most of these rights exist in BusinessObjects 
Enterprise 6.x as Web Intelligence application security commands in the 
InfoView category. 
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General  Right Description Impact in InfoView if this right is disabled 

Change user's 
preferences     

Allows you to change your 
InfoView preferences such as 
Web Intelligence default viewer 
or fields displayed. 

• Click the Personalize InfoView now link; 
an error message is displayed. 

• On the toolbar, the Preferences icon is 
disabled. 

Organize     Allows you to move or copy files, 
add them to favorites or create 
shortcut to them.  

On the toolbar, the Organize menu is disabled. 

Search for simple text   Allows you to run simple search. The Search > Search all fields, Search > Search 
title and Search > Search keywords commands, 
the Search text field and Execute search icon are 
all disabled. 

NOTE: The Search > Advanced search… 
command remains still available. 

Do an advanced 
search     

Allows you to run advanced 
search. 

The Search > Advanced search… command is 
disabled. 

Filter object listing by 
object type     

Allows you to filter objects in 
objects list. 

On the toolbar, the Filter scroll-down menu is 
disabled. 

View the favorites 
folder     

Allows you to use, view or access 
your Favorites folder. 

In the left panel navigation tree, the Home > 
Favorites branch is not displayed. 

View the Inbox     Allows you to use, view or access 
your Inbox folder. 

• In the left panel navigation tree, the Home 
> Inbox branch is not displayed. 

• In the InfoView homepage, the Go to 
InfoView Inbox link is not displayed. 

Create categories     Allows you to create personal or 
public categories. The Add 
objects to the folder right must 
also be granted for the category 
where the new category will be 
created. 

On the New menu, the Category command is 
disabled. 

Assign categories     Allows you to modify Personal or 
Favorites categories assigned to 
documents. Some rights must 
also be granted at category and 
document levels (see Add a 
Document into a Category on 
page 90). 

In document lists, click a document’s Properties 
link; the list of personal and corporate 
categories is disabled. 

Send documents     Allows you to send a document 
to Email, Inbox, FTP location or 
File location. 

On the toolbar, the Send button is disabled. 
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General  Right Description Impact in InfoView if this right is disabled 

Create dashboards     Allows you to create additional 
InfoView dashboard. This right 
does not prevent you to edit My 
InfoView dashboard. 

The New > Single Dashboard command is 
disabled. 

Create folders     Allows you to create folder 
(Personal or Public). The Add 
objects to the folder right must 
also be granted for the folder 
where the new folder will be 
created. 

The New > Folder command is disabled. 

 

Web Intelligence Rights 
Web Intelligence has two viewers that are both impacted by rights (the PDF 
viewer is not impacted): 

• HTML Viewer  

• Interactive Viewer (Java system only, not .NET) 

Web Intelligence has three query panels that are all impacted by rights:  

• Java Report Panel 

• Query - HTML (Java system only, not .NET) 

• HTML Report Panel (Java system only, not .NET) 

NOTE We recommend you use the Java Report Panel or Query - HTML query panels. 

 

The following table lists the Web Intelligence application rights and how they 
impact these viewers and query panels. 

Custom Right Description Impact if this right is denied 

Java Report 
Panel: Edit SQL  

Allows you to modify the 
SQL used by the query. 
The View SQL and Edit 
Query rights must also be 
granted for this 
document. 

Java Report Panel: On the toolbar, click the Edit Query 
button to open the Query Editor. Click the Query toolbar, 
click the View SQL button; in the SQL Viewer dialog box, 
the Use Custom SQL radio button is disabled, the SQL text 
is not editable, and the Undo, Validate and Save buttons 
are not displayed. 

 

Merge 
dimensions for 
synchronization 

Allows you to merge 
objects (dimensions only) 
belonging to different 
data providers. 

 

Java Report Panel: In the Reporting toolbar, the Merge 
Dimensions button is disabled.  

Interactive Viewer: In the left pane, select the Available 
Objects choice in the scroll-down list to display the objects; 
the Merge button is disabled. 
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Custom Right Description Impact if this right is denied 

Enable interactive 
HTML viewing (if 
license permits) 

Allows you to display a 
Web Intelligence 
document through the 
Interactive Viewer. 

InfoView: On the toolbar, click the Preferences button, 
click the Web Intelligence Document tab; the Interactive 
Viewer check box is not displayed. If it was the previous 
choice, it is set to another granted viewer. 

Enable Query – 
HTML 

Allows you to edit or 
create a new Web 
Intelligence document 
through the Query – 
HTML. 

InfoView: On the toolbar, click the Preferences button, 
then the Web Intelligence Document tab;  the Query - 
HTML check box is not displayed. If it was the previous 
choice, it is set to another granted query panel. 

Enable HTML 
Report Panel 

Allows you to edit or 
create a new Web 
Intelligence document 
through the HTML 
Report Panel. 

InfoView: On the toolbar, click the Preferences button, 
then the Web Intelligence Document tab; the HTML 
Report Panel check box is not displayed. If it was the 
previous choice, it is set to another granted query panel. 

Enable Java 
Report Panel 

Allows you to edit or 
create a new Web 
Intelligence document 
through the Java Report 
Panel. 

InfoView: On the toolbar, click the Preferences button, 
then the Web Intelligence Document tab; the Java Report 
Panel check box is not displayed. If it was the previous 
choice, it is set to another granted query panel. 

Extend scope of 
analysis  

Allows you to drill out of 
scope and to retrieve 
additional data from the 
data source. The Enable 
drill mode right must 
also be granted to extend 
scope of analysis. The 
level of analysis is 
defined in the query 
definition, in the Scope of 
Analysis parameter 
(None, one, two or three 
levels).  

HTML Viewer/ Interactive Viewer: Create or open a 
drillable document. Click the Start Drill Mode button; the 
drill links are not available to drill beyond the document’s 
scope of analysis. 

Java Report Panel: Create or open a drillable document. 
Click the Drill button; the drill links are not available to 
drill beyond the document’s scope of analysis. 

 

Enable drill mode Allows the users to drill 
in the report. 

HTML Viewer/Interactive Viewer: Create or open a 
drillable document; the Start Drill mode button is not 
displayed. 

Java Report Panel: Create or open a drillable document: the 
Drill button is disabled. 

Create document  

 

Allows you to create a 
new Web Intelligence 
document. 

InfoView: On the New menu, the Web Intelligence 
command is not displayed. 

Java Report 
Panel: Enable 
formula toolbar 

 

In the Java Report Panel, 
allows you to use the 
formula toolbar. 

Java Report Panel:  

• On the interactive editing menu (right-click), the 
Formula toolbar… command is not displayed.  

• The Formula toolbar is not displayed in the report 
panel. 
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Custom Right Description Impact if this right is denied 

Interactive: 
General - Enable 
right click menu 

In the Interactive Viewer, 
allows you to open the 
contextual menu through 
the right-click. 

Interactive Viewer: Right-click does not display the 
interactive editing menu 

 

Interactive: Left 
pane - Enable 
document 
summary 

Allows you to display the 
document summary in 
the left pane of the 
Interactive Viewer. 

Interactive Viewer: On the left-pane scroll-down menu, the 
Document Summary option is not displayed. 

Interactive: Left 
pane - Enable 
data summary 

Allows you to display the 
data summary in the left 
pane of the Interactive 
Viewer. 

Interactive Viewer: On the left-pane scroll-down menu, the 
Data Summary option is not displayed. 

Interactive: Left 
pane – Enable 
document 
structure and 
filters 

Allows you to display the 
document structure and 
filters in the left pane of 
the Interactive Viewer. 

Interactive Viewer: On the left-pane scroll-down menu, the 
Document Structure and Filters option is not displayed. 

Interactive: Left 
pane - Enable 
available objects, 
tables and charts 

Allows you to display the 
list of available objects, 
tables and charts in the 
left pane of the 
Interactive Viewer. 

Interactive Viewer: On the left-pane scroll-down menu, the 
Available Objects and Chart and Table Types options are 
not displayed. 

Interactive: 
Formatting - 
Enable toolbar 
and menus 

Allows you to use 
formatting features in the 
Interactive Viewer. 

Interactive Viewer:  

• On the View > Toolbars menu, the Formatting 
command is not displayed.  

• On the interactive editing menu (right-click), the 
Format command is not displayed. 

Interactive: 
Reporting - 
Create and edit 
report filter  

Allows you to create and 
edit filters in the 
Interactive Viewer. 

Interactive Viewer:  

• On the interactive editing menu (right-click) or the 
report toolbar, the Quick Filter option or button is not 
displayed. 

Interactive: 
Reporting - 
Create and edit 
sort 

Allows you to create and 
edit sorts in the 
Interactive Viewer. 

Interactive Viewer:  

• On the Report toolbar, the Sort button is not displayed.  

• On the interactive editing menu (right-click), the Sort 
option is not available. 

Interactive: 
Reporting - 
Create and edit 
break  

Allows you to create and 
edit breaks in the 
Interactive Viewer. 

Interactive Viewer:  

• On the Report toolbar, the Break button is not 
displayed.  

• On the interactive editing menu (right-click), the Break 
command is not available. 
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Custom Right Description Impact if this right is denied 

Interactive: 
Reporting – 
Create and edit 
predefined 
calculation  

Allows you to create and 
edit predefined 
calculations in the 
Interactive Viewer. 

Interactive Viewer: On the Report toolbar, the Calculations 
button is not displayed. 

Interactive: 
Reporting - 
Create and edit 
alerters 

In the Interactive Viewer, 
allows you to create and 
edit alerters. 

Interactive Viewer: On the Report toolbar, the Alerters 
button is not displayed.  

Interactive: 
Reporting - Insert 
report, table, 
chart and cell  

Allows you to insert 
report, table, chart and 
cell in the Interactive 
Viewer. 

Interactive Viewer: On the interactive editing menu (right-
click); the Set as section, Insert, Turn table into…, Swap 
axis, Remove commands are not displayed. 

Interactive: 
Formula - Enable 
toolbar and 
variable creation 

Allows you to use 
formula features in the 
Interactive Viewer. 

Interactive Viewer:  

• The Formula toolbar is not displayed.  

• On the View menu, the Formula command is not 
displayed. 

Interactive: 
General - Ability 
to hide / show 
toolbars 

Allows you to show or 
hide the Formatting, 
Report, Formula toolbars 
in the Interactive Viewer. 

Interactive Viewer:  

• On the View menu, the Toolbars command is not 
displayed.  

• The toolbars displayed in the Interactive Viewer are the 
ones that were allowed to display before this right was 
denied. 

Interactive: 
General - Edit My 
Preferences   

Allows you to edit the 
preferences for 
Interactive Viewing. 

Interactive Viewer: On the View menu, the Preferences 
command is not displayed 

 

Desktop Intelligence Rights 
Most Desktop Intelligence rights are previous BusinessObjects version 6.x 
security commands that have been implemented in BusinessObjects XI Release 
2 at the application and document level (see Desktop Intelligence Document 
Rights, on page 58).   

Desktop Intelligence has different modes: 

• Connected - In this mode, you need to provide credentials that are checked 
against the CMS, which returns a list of your rights.  

• Offline - Credentials are also needed, but they are not required to be 
connected to the CMS. Indeed, credentials are checked against a cache that 
returns the rights saved from a previous log on to the CMS. 

• Standalone - No credentials are needed to log into Desktop Intelligence in 
this mode. Anyone can log in this mode and no rights apply. Nevertheless, 
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only documents that have been saved with the Save for all users option 
can be opened in this mode.  

NOTE Connected and Offline modes support Enterprise, LDAP, Windows NT or Active Directory 
Authentication. 

 

Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Create 
Desktop 
Intelligence 
Documents  

Allows you to create a new 
document. 

 

• On the Standard toolbar, the New button is disabled. 

• On the File menu, the New command is disabled. 

• On the Tools menu, select the Options command and in 
the Options dialog box the New Document tab is not 
displayed. 

• On the Tools menu, select the Options command, select 
the General tab in the Options dialog box, the Show 
Welcome Wizard option is disabled under Start-Up 
Options. 

• On the Standard toolbar, the New Report Wizard button 
is disabled. 

InfoView: On the New menu, the Desktop Intelligence 
command is not displayed. 

Create 
Templates  

Allows you to save 
documents as templates. 

 

On the File menu, select the Save As command; in the Save As 
dialog box, Desktop Intelligence Templates (*.ret) does not 
appear in the Save as type list. 

Use 
Templates 

Allows you to create 
reports with templates or 
apply templates to existing 
reports. 

Start Desktop Intelligence or in the File menu, select the New 
command. The New Report Wizard starts with the Specify 
Data Access panel, instead of the Welcome panel that offers 
the choice to create a new document from a template. 

Save Desktop 
Intelligence 
Documents 

Allows you to save 
documents locally (outside 
the CMS). If the Save for 
all users option is not 
selected, then you are the 
only user  allowed to open 
the saved document.  

• On the Standard toolbar, the Save button is disabled. 

• On the File menu, the following commands are disabled: 

• Save 

• Save As 

• Save As HTML 

• Save All 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Save 
documents 
for all users 

Allows you to save 
documents without 
security constraints for 
offline use in order to 
allow all users to view this 
document saved locally. 

The right Save Desktop 
Intelligence Documents 
must also be granted to 
perform this action. 

On the File menu, select the Save As command; in the Save As 
dialog box, the Save for all users check box is disabled. 

Desktop 
Intelligence 
Document 
Interaction 

Allows you to rename, 
duplicate, insert or delete a 
report in a document. 

 

• On the Insert menu, the Report command is disabled. 

• On the Edit menu, the Duplicate Report and Delete 
Report commands are disabled. 

• On the Format menu, select the Report command; on the 
submenu, the Rename command is disabled. 

• Right-click a report tab in a document (at the bottom of the 
report); on the shortcut menu, the following commands 
are disabled: 

• Rename Report 

• Insert Report 

• Duplicate Report 

• Delete Report 

Desktop 
Intelligence 
Report 
Interaction 

Allows you to select 
individual elements of a 
report to cut, copy, clear, 
duplicate or delete. 

 

• You cannot select any part of a report such as the title, cell, 
graphic, or crosstab. As a result, no right-click shortcut 
menu is displayed for them and the following commands 
on the Edit menu are not available: 

• Cut 

• Copy 

• Clear 

• Delete 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Refresh 
Desktop 
Intelligence   
Document 

Allows you to refresh 
documents. This right 
interacts with the 
document Refresh the 
report’s data right. See also 
Refresh a Desktop 
Intelligence document, on 
page 88. 

 

• On the Data menu, the Refresh Data, Edit Data Provider 
and New Data Provider commands are disabled. 

• On the Insert menu, select the Table, Crosstab or the 
Chart command; click in the current report; in the New 
Table Wizard, the choices Build a new query on the 
universe currently in use and Access new data in a 
different way are not offered. 

• Click the View Data button on the Standard toolbar or, on 
the Data menu, click View Data; In the Data Manager 
window, select the Results tab: 

• The Refresh button is disabled. 

• Click Options; in the Query Options dialog box, the 
Do Not Retrieve Data option is selected and disabled. 

Select the Definition tab: 

• The Refreshable option is disabled. 

• The Automatic Refresh option is disabled. 

• The … button next to the Universe name, which calls 
the Change Universe dialog box, is disabled. 

• Launch Desktop Intelligence or if it is already started, click 
File > New > Generate a Standard Report in the New 
Report Wizard, click Begin and the Universe option for 
data access is disabled. 

HTML Viewer: This right interacts with the document 
Refresh the report’s data right: 

• If this document right is granted, then the Refresh Data 
button is displayed on the viewer toolbar. Click this button 
and if the application right is denied, a separate error 
message box appears. 

• If this document right is denied the Refresh Data button is 
not displayed regardless of the application right value.  

Print 
Documents 

Allows you to print 
documents. 

 

• On the File menu, the following commands are disabled: 

• Print 

• Print Preview 

• Page Setup 

• On the Standard toolbar, the following buttons are 
disabled: 

• Print 

• Print Preview 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Copy to 
Clipboard 

Allows you to cut or copy 
material to the clipboard. 

 

• On the Standard toolbar, the Cut and Copy buttons are 
disabled. 

• On the Edit menu, Cut, Copy and Copy All are disabled 

• Select a title, cell or table. Right-click to open the shortcut 
menu; the Cut and Copy commands are disabled. 

• Click the View Data button on the Standard toolbar or on 
the Data menu click View Data; in the Data Manager 
dialog box, select the results tab and click Export; in the 
Export to External Format dialog box, the Copy to DDE 
option is disabled. 

Euro 
Converter 

Allows you to convert 
currency figures in reports 
to and from Euros. 

 

Select a currency figure in a report; on the Data menu click 
Euro; on the submenu all the commands are disabled: 

• Convert to Euros 

• Convert from Euros 

• Display Rounding Errors 

• Display Conversion Rates 

Edit Euro 
Converter 
Rate 

Allows you to modify the 
Euro exchange rates used 
by the Euro Converter 
function. 

Select a currency figure in a report; on the Data menu, click 
Euro, click Display Conversion Rates; the Add, Remove, and 
Edit buttons are disabled in the Conversion Rates dialog box. 

Drill 
Through 

Allows you to drill further 
in a report by retrieving 
new data. 

Open a report; click Drill on the Standard toolbar, or select 
Drill from the Analysis menu; in the report, select a cell; on 
the Analysis menu or if you right-click a cell, the Drill 
Through command is disabled. 

Edit Scope of 
Analysis 

Allows you to edit the 
Scope of Analysis. 

 

Open a report, click the Drill button on the Standard toolbar 
or click Drill on the Analysis menu. In the report, select a cell; 
on the Analysis menu or if you right-click a cell, the Scope of 
Analysis command is disabled. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Work in Drill 
Mode 

Allows you to drill down 
to a finer level of analysis 
in reports. 

 

• The Drill button on the Standard toolbar is disabled. 

• Right-click a report tab in the document (at the bottom of 
the report);  the Drill command on the shortcut menu is 
disabled. 

• On the Tools menu, click Options: in the Options dialog 
box, the Drill tab is not displayed.  

• On the Analysis menu, the following commands are 
disabled: 

• Drill 

• Drill Down 

• Drill Up 

• Expand 

• Collapse 

• Snapshot 

• Hierarchies 

• Scope of Analysis 

Work in 
Slice-and-
Dice Mode 

Allows you to use the Slice 
and Dice Panel. 

• The Slice and Dice button on the Standard toolbar is not 
available. 

• On the Analysis menu, the Slice and Dice command is 
disabled. 

Edit VBA 
Code 

Allows you to edit VBA 
macros used in reports. 

 

• Open a document containing a VBA macro; on the Tools 
menu, click Macro or, on the Visual Basic toolbar, click the 
Edit Macros button; the Visual Basic Editor submenu 
command is disabled. 

• Open a document containing a VBA macro; on the Tools 
menu, click Macro or, on the Visual Basic toolbar, click the 
Edit Macros button; click Macros; in the Macros dialog 
box, all options except Run, Cancel and Help are disabled. 

• Open a document containing a VBA macro; on the Visual 
Basic toolbar, all the buttons are disabled. 

NOTE: Even if this right is denied, if the VBA code is called 
from the Document_Open() call, the VBA code will be 
executed. 

Run VBA 
Code 

Allows you to run VBA 
code. 

Open a document containing a VBA macro; on the Tools 
menu, click Macro or, on the Visual Basic toolbar, click the 
Edit Macros button; click Macros: in the Macros dialog box, 
the Run option is disabled. 

NOTE: Even if this right is denied, if the VBA code is called 
from the Document_Open() call, the VBA code will be 
executed. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Install Add-
Ins 

Allows you to install or 
uninstall VBA add-ins. 

On the Tools menu, the Add-Ins command is disabled. 

Manage All 
Corporate 
Categories 

Allows you to create, edit 
or delete any corporate 
categories from within 
Desktop Intelligence 
application. 

On the File menu, select the Export to Repository command. 
In the Export window, click the Categories button. In the 
Select Categories window, click Manage. In the Categories 
window, when you select a corporate category, the Add, 
Delete and Edit buttons are disabled. 

If both Manage All Corporate Categories and Manage My 
Corporate Categories rights are denied, then the Manage 
button in the Select Categories window is disabled. 

Manage My 
Corporate 
Categories 

Allows you to create, edit 
or delete personal 
categories from within 
Desktop Intelligence 
application. 

On the File menu, select the Export to Repository command. 
In the Export window, click the Categories button. In the 
Select Categories window, click Manage. In the Categories 
window, when you select a personal category, the Add, Delete 
and Edit buttons are disabled. 

If both Manage All Corporate Categories and Manage My 
Corporate Categories rights are denied, then the Manage 
button in the Select Categories window is disabled. 

Refresh 
Document 
List and 
Categories 

Allows you to refresh 
categories lists and their 
contents. 

• On the File menu, select the Export to Repository... 
command. In the Export window, click the Categories… 
button. In the Select categories window, the Refresh 
button is disabled. 

• On the File menu, select the Import from Repository 
command. In the Import window, click the Categories 
radio button. the Refresh button is disabled. 

Send 
Documents 
to Repository 

 

Allows you to publish a 
document in the CMS, in 
the Public Folders or your 
Personal Folders. The Add 
objects to this folder right 
must also be granted for 
this folder. 

On the Document Exchange toolbar or the File menu, the 
Export to Repository… button or command is disabled. 

 

Send 
Documents 
to Mail 

Allows you to send 
documents as email from 
Desktop Intelligence. 

On the Document Exchange toolbar or the File menu, the 
Send to Mail… button or command is disabled. 

Retrieve 
documents 

 

Allows you to retrieve 
documents from the CMS, 
both Personals or Public 
documents. 

On the Document Exchange toolbar or the File menu, the 
Import from Repository button or command is disabled. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Create And 
Edit 
Connections 

Allows you to create a new 
connection or edit an 
existing one. 

 

• Click the View Data button on the Standard toolbar or on 
the Data menu select View Data. Click Export in the Data 
Manager dialog box. In the Export to External Format 
dialog box, below the Export to RDBMS option, the 
Connection button is disabled. 

• Open a document based on a Free-hand SQL Data 
Provider or in the New Report wizard, go to the Specify 
Data Access step and select Free-Hand SQL. In the Free-
Hand SQL Editor, the Create Connection and Edit 
Connection buttons are disabled. 

Data 
Provider 
Manipulation 

Allows you to modify a 
query or change the 
universe it is based on. 

 

• On the Data menu, the New Data Provider command is 
disabled. 

• On the Data menu, select View Data; in the Data Manager 
dialog box, under Data Providers: 

• The Edit button is disabled. 

• The Delete button is disabled. 

• In the Definition tab of the Data Manager dialog box: 

• The Editable option is disabled. 

• The button next to the Universe name, which is used 
to call the Change Universe dialog box, is disabled. 

• Click the Insert Table (or Insert Crosstab, or Insert Chart) 
button on the Report toolbar, or select the Table (or 
Crosstab, or Chart) command on the Insert menu. Click in 
the report to point out the new item location. In the New 
Table wizard (or New Crosstab or New Chart wizard), 
you do not have the option to select another Data 
Provider. You can only use the existing data, variables and 
formulas in the document. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Edit Free-
hand SQL 

Allows you to edit a query 
which uses free-hand SQL 
scripts as a data provider. 
The Use Free-hand SQL 
right must also be granted 
to perform this action. 

 

• In the New Report wizard, go to the Specify Data Access 
step; Free-Hand SQL does not appear in the Others list of 
data providers. 

• Click the Insert Table (or Insert Crosstab, or Insert Chart) 
button on the Report toolbar, or select the Table (or 
Crosstab, or Chart) command on the Insert menu. Click in 
the report to point out the new item location. In the New 
Table wizard (or New Crosstab or New Chart wizard), 
select the Access New Data in a different way radio 
button, then click the Begin button: the Free Hand-SQL 
option does not appear in the scroll-down menu under the 
Others radio button. 

• On the Tools menu, click Options > New Document tab > 
Use a Different Data Provider; in the scroll down menu, 
the Free-Hand SQL choice is not offered. 

• Open a document made with free-hand SQL scripts; on the 
Standard toolbar, click the Edit Data Provider button or, 
on the Data menu, click Edit Data Provider; if the List of 
Data Providers dialog box appears, click the script you 
want to edit, then OK; in the Free-Hand SQL dialog box, 
all items are disabled: 
• The Open, Save and Parse buttons 
• The list of connections 
• The Test the connection,  Edit connection and Create 

a new connection buttons 
• The text field containing the SQL itself 
• The Build Hierarchies and Start in Drill Mode check 

box 
• The Help button. 

Use Free-
hand SQL 

Allows you to create a 
query using free-hand SQL 
scripts as a data provider. 

This right does not prevent 
refreshing a document 
based on Free-hand SQL. 

All the effects of the Edit Personal Data Files right described 
on the next row plus the View and Run buttons in the Free-
Hand SQL dialog box are disabled. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Edit Personal 
Data Files 

Allows you to edit 
personal data provider 
(Excel, dBase or ASCII 
files) parameters. 

 

• Open a document that was created using personal data 
files (Excel, dBase or ASCII text files). On the Standard 
toolbar: 

• click the Edit Data Provider button or on the Data 
menu, click Edit Data Provider;  

• click the View Data button or on the Data menu, click 
View Data; in the Data Manager dialog box, click 
Edit; 

In the Access Personal Data dialog box, all the options in 
the File and Text File or Worksheet/Workbook File 
sections are disabled.  

• In the New Report wizard, go to the Specify Data Access 
step; the Personal Data Files option does not appear in the 
Others list of data providers.  

• Click the Insert Table (or Insert Crosstab, or Insert Chart) 
button on the Report toolbar, or select the Table (or 
Crosstab, or Chart) command on the Insert menu. Click in 
the report to point out the new item location. In the New 
Table wizard (or New Crosstab or New Chart wizard), 
select the Access New Data in a different way radio 
button, then click the Begin button. The Personal Data 
Files choice does not appear in the scroll-down menu 
under the Others radio button.  

Use Personal 
Data Files 

Allows you to create a 
report using Excel, dBase 
or ASCII text files as a data 
provider. 

This right does not prevent 
refreshing a document 
based on Personal Data 
Files.  

• All the effects of the Edit Personal Data Files right plus 
the View and Run options in the Access Personal Data 
dialog box are disabled. 

• On the Tools menu, click Options > New Document tab > 
Use a Different Data Provider. In the scroll down menu, 
the Personal Data Provider choice is not displayed. 

Edit Stored 
Procedures 

Allows you to edit stored 
procedures parameters. 

 

• Open a document based on a stored procedure; on the 
Standard toolbar, click the Edit Data Provider button or, 
on the Data menu, click Edit Data Provider; in the dialog 
box that appears, all options are unavailable. 

• Open a document based on a stored procedure; on the 
Standard toolbar, click the View Data button or, on the 
Data menu, click View Data; in the Data Manager dialog 
box, click Edit; in the dialog box that appears, all options 
are unavailable. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Use Stored 
Procedures 

Allows you to create a 
report using a Stored 
Procedure as a data 
provider. 

 

 

• On the File menu, click Open or, on the Standard toolbar, 
click the Open button; in the Open dialog box, select a 
document built using stored procedures and click Open; 
the document will not open and you will receive an error 
message telling you that you are not authorized to use the 
document. 

• In the New Report wizard, go to the Specify Data Access 
step; Stored Procedures does not appear in the Others list 
of data providers. 

• Click the Insert Table (or Insert Crosstab, or Insert Chart) 
button on the Report toolbar, or select the Table (or 
Crosstab, or Chart) command on the Insert menu. Click in 
the report to point out the new item location. In the New 
Table wizard (or New Crosstab or New Chart wizard), 
select the Access New Data in a different way radio 
button, then click the Begin button. The Stored Procedure 
choice does not appear in the scroll-down menu under the 
Others radio button. 

• On the Tools menu, click Options > New Document tab > 
Use a Different Data Provider. In the scroll down menu, 
Stored Procedures is not displayed. 

Always 
Regenerate 
SQL 

Forces the queries’ SQL 
queries to be regenerated 
with each refresh.  

Granting this right may be 
very impacting in term of 
performance. So, if there is 
no special requirement to 
regenerate the SQL queries 
with each refresh, it is 
recommended to set this 
right to Not Specified or 
Denied. 

No impact on the User Interface. The SQL of the query is not 
regenerated with each refresh cycle. 

Edit Query 
SQL 

Allows you to modify the 
SQL of queries. 

To modify the SQL request, 
the Edit Queries and View 
SQL rights must also be 
granted.  

• On the Standard toolbar, click the Edit Data Provider 
button or, on the Data Menu, select the Edit Data Provider 
command; in the Query panel, click the View SQL button: 
in the SQL Viewer dialog box, the Regenerate and Parse 
buttons and the Do not generate SQL before running 
check box are disabled. 

• On the Standard toolbar, click the View Data button or, on 
the Data Menu, select the View Data command; in the 
Data Manager dialog box, click Edit; in the Query panel, 
click the View SQL button: in the SQL Viewer dialog box, 
the Regenerate and Parse buttons and the Do not generate 
SQL before running check box are disabled. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Use other 
SQL requests 
than Select. 

Allows you to use different 
clauses in the SQL than 
SELECT.   

To modify the SQL request, 
the Edit Queries, View 
SQL and Edit Query SQL 
rights must also be 
granted. 

None. When it is denied and the restriction applies, you will 
receive an error message if you try to send anything but 
SELECT clauses in your SQL. 

View SQL Allows you to see the SQL 
generated for the query. 

• On the Standard toolbar, click the Edit Data Provider 
button or on the Data menu, select Edit Data Provider. In 
the Query panel, the View SQL button on the toolbar is 
disabled. 

• On the Standard toolbar, click the View Data button or on 
the Data menu, select View Data. In the Data Manager 
dialog box, click Edit. In the Query panel, the View SQL 
button on the toolbar is disabled. 

Edit Queries Allows you to modify 
queries. 

• In the New Report wizard, go to the Specify Data Access 
step; you can select a universe but in the Query Panel, it is 
not possible to modify the query. 

• On the Standard toolbar, the Edit Data Provider button is 
disabled. 

• On the Data menu, the Edit Data Provider command is 
disabled. 

• On the Standard toolbar, click the View Data button or, on 
the Data menu, click View Data; in the Data Manager 
dialog box, the Edit button is disabled. 

• Click the Insert Table (or Insert Crosstab, or Insert Chart) 
button on the Report toolbar, or select the Table (or 
Crosstab, or Chart) command on the Insert menu. Click in 
the report to point out the new item location. In the New 
Table wizard (or New Crosstab or New Chart wizard), 
select the Build a new query based on the universe 
currently in use or Use an existing query to build a new 
one. The Query panel appears but it is not possible to 
modify the query. 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Use Queries Allows you to create new 
queries based on universe. 

 

• In the New Report wizard, go to the Specify Data Access 
step and the Universe radio button choice is disabled. 

• On the Tools menu, click Options > New Document tab.  
Under Data Access, the Select a Universe and Use the 
Default Universe radio buttons choice are disabled. 

• Open a report and, on the Insert menu, click Table (or  
Crosstab or Chart) or on the Report toolbar, click the 
Table (or Crosstab or Chart) button. Click in the report; in 
the Insert a New Table (or Crosstab or Chart) wizard, the 
Build a new query on the universe currently in use radio 
button choice is disabled. 

• On the Data menu, click New Data Provider. In the Insert 
New Data wizard, the Build a new query on the universe 
currently in use radio button choice is disabled. 

Edit List of 
Values 

Allows you to edit lists of 
values defined in 
universes. 

On the Tools menu, select Universes. In the Universes dialog 
box, select a universe and click the Lists of Values button. In 
the Lists of Values dialog box, select an object; the Edit button 
is disabled. 

Use List of 
Values 

Allows you to use lists of 
values defined in 
universes. 

 

• On the Tools menu, click Universes. In the Universes 
dialog box, the Lists of Values button is disabled. 

• On the Standard toolbar, click the Edit Data Provider 
button or, on the Data menu, select Edit Data Provider; in 
the Conditions pane of the Query panel, add or modify a 
condition that includes operands; Show list of values does 
not appear in the list of operands in the left-hand pane.  

• On the Standard toolbar, click the View Data button or, on 
the Data menu, select View Data; in the Data Manager 
dialog box, click Edit; in the Conditions pane of the Query 
panel, add or modify a condition that includes operands; 
Show list of values does not appear in the list of operands 
in the left-hand pane 
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Custom 
Right 

Description Impact in Desktop Intelligence if this right is denied 

Refresh List 
of Values 

Allows you to refresh lists 
of values in universes. 

 

 

• On the Standard toolbar, click the Edit Data Provider 
button or on the Data menu, click Edit Data Provider. In 
the Conditions pane of the Query panel, add or modify a 
condition; in the condition, select an operand and double-
click Show list of values in the list of operands in the left-
hand pane. In the List of Values dialog box, the Refresh 
button is disabled. 

• On the Standard toolbar, click the View Data button or on 
the Data menu, click View Data in the Data Manager 
dialog box and click Edit. In the Conditions pane of the 
Query panel, add or modify a condition; in the condition, 
select an operand and double-click Show list of values in 
the list of operands in the left-hand pane. In the List of 
Values dialog box, the Refresh button is disabled. 

• On the Tools menu, click Universes. In the Universes 
dialog box, select a universe and click Lists of Values; in 
the Lists of Values dialog box, the Edit, Purge and 
Refresh buttons are disabled. Select an object and click 
Display; in the List of Values of... dialog box, the Refresh 
button is disabled. 

Use User 
Objects 

Allows you to create, edit 
or delete user objects. 

 

 

• On the Tools menu, click Universes; in the Universes 
dialog box, the User Objects button is disabled. 

• On the Standard toolbar, click the Edit Data Provider 
button or on the Data menu, click Edit Data Provider; in 
the Query panel, the User Objects button on the toolbar is 
disabled. 

• On the Standard toolbar, click the View Data button or on 
the Data menu, click View Data. In the Data Manager 
dialog box, click Edit; in the Query panel, the User 
Objects button on the toolbar is disabled. 

Designer Rights 
These rights cover some general features in the Designer. Some more granular 
rights can also be directly set at universe or connection level (see Universe 
Rights, on page 77 or Connection Rights, on page 82). 

Custom Right Description Impact in Designer if this right is disabled 

Check Universe 
Integrity 

Allows you to check universe 
integrity. 

On the Tools menu or the Editing toolbar, the Check 
Integrity command or button is disabled. 

Refresh 
Structure 
Window 

Allows you to refresh the 
structure window. 

On the View menu, the Refresh Structure command is 
disabled. 
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Custom Right Description Impact in Designer if this right is disabled 

Use Table 
Browser 

Allows you to use view 
database data with the table 
browser. 

• On the Insert menu, the Tables command is disabled. 
• On the Editing toolbar, the Table Browser button is 

disabled. 
• Double-click the Structure Window; the Table 

Browser does not appear. 
Apply 
Universe 
Constraints 
 
 

Allows you to apply to the 
users of an imported universe 
the overload constraints 
made on that universe. 

There are no effects on the user interface.  
Granted: when a designer imports a universe to which 
connection overload has been applied, those constraints 
apply to the universe as it is imported and exported back 
to the CMS. 
Denied: when a designer imports a universe to which a 
connection overload has been applied, those overloads do 
not apply to the universe as it is imported and exported 
back to the repository. 

Link Universe Allows you to link two 
universes to share 
components. 

• On the Edit menu, the Links command is disabled. 
• On the Insert menu, the Universe command is 

disabled. 
• On the File menu, select Parameters or, on the 

Standard toolbar, click the Parameters button. In the 
Universe Parameters dialog box, select the Links tab; 
the Add Link… and Change Source… buttons are 
disabled. 

Create, Modify 
or Delete 
Connections 

Allows you to create, modify 
or delete Universe 
Connections that are stored in 
the CMS (secured) or as 
Personal/Shared 
Connections. 

In the Connection List panel, the Add, Delete and Edit 
buttons are disabled. 

 

NOTE The Create, Modify or Delete Connections right has been introduced in 
BusinessObjects XI Release 2 SP2. 

 

Performance Management Rights 
All Performance Management products are located in the Performance 
Management application, but Performance Management’s rights are organized 
into several sets: 

• Analysis contains only rights for Set Analysis. 

• App Foundation contains rights to allow users to access different menus 
or sections in Dashboard Manager, Set Analysis, Process Analysis or 
Predictive Analysis. 

• Configuration contains rights to allow users to run some tasks in 
Dashboard Manager, Set Analysis, Process Analysis or Predictive Analysis. 
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• Rules contains rights associated to rules, especially the actions that can be 
triggered by rules. 

• Services Bar contains rights that enable icons displayed in the toolbar. 

To access any Performance Management products, the user must at least have 
the following rights granted:  

• The Service Bar/Access to Performance Management right for the 
Performance Management application  

• The Use Performance Management right for the Performance 
Management application  

• The Log on to InfoView and view this object in the CMC right for the 
InfoView application. 

Some products have their rights listed in different sets. For example, to have 
complete access to Predictive Analysis, the following rights must be granted: 

Rights Set Right 

Access to Population Definition 

Access to Derived Variables 

App Foundation 

Access to Model Definition 

Edit Populations - Controls the ability to create, edit, or 
remove populations 

Edit Derived Variables - Controls the ability to create, 
edit, or remove derived variables 

Edit Models - Controls the ability to create, edit, copy, 
or remove models 

Edit Data Mining Metrics - Controls the ability to create, 
edit, or remove data mining metrics 

Edit Binning - Controls the ability to create, edit, or 
remove bins for predictive analysis 

Configuration 

Refresh Statistics or Regenerate Model 

   

NOTE There is a known issue in BusinessObjects XI Release 2. If a right is granted for 
Performance Manager at the group level and then denied or not specified at the user 
level, the application does not take into consideration the overwrite at the user level; 
although the right is correctly set in the CMC. This issue has been logged under 
ADAPT00734218. 

Analysis 
These three rights concern features available to the Individual Profiler.  The 
following Performance Management’s rights must also be granted to access 
Individual Profiler: 

• Configuration/Schedule Sets Refresh 
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• App Foundation/ Access to Sets Menu. 

The Individual profiler must have been configured first by the Administrator, 
otherwise the user is not able to access this page.  

If the profiler is not configured, an error message box appears. In order to 
configure the profiler, go to Setup > parameters> Individual profiler.  Select 
the Set Name and select the fields for query box and Header&Portrait. On save 
this, we can access the portrait option in Set Analysis. 

Right Description Impact in Performance Management if this 
right is denied 

Individual Profiler 
- Access to Portrait    

In Set Analysis,  allows you to 
access the page to manage 
Individual Portrait. 
See above the requirements to 
access Individual Profiler. 

In Set Analysis, click the Individual link. Then, 
in the Analysis section 
• Click Individual Portrait;  an error message 

is displayed on the page.  
• Click Profiler; in the Profiler page, the 

Portrait link is not displayed. 
Individual Profiler 
- Access to 
Membership     

In Set Analysis,  allows you to 
access and create Membership 
analytics that allow you to view the 
selected set for the specified period. 
The following Performance 
Management’s rights must also be 
granted to be able to manage 
Membership: 
• Configuration/Schedule Sets 

Refresh  
• App Foundation/Access to Sets 

Menu 
See above the requirements to 
access Individual Profiler. 

In Set Analysis, click the Individual link: 
•  In the Membership section, click the 

Current Membership, Membership 
History or Membership Summary links; an 
error message is displayed on the page. 

• In the Analysis section, click Profiler. In the 
Profiler Page, the Current Membership, 
Membership History and Membership 
Summary links are not displayed. 

Individual Profiler 
- Access to Metrics    

In Set Analysis, allows you to 
access the page to list metrics 
associated to sets.     
See above the requirements to 
access Individual Profiler. 

In Set Analysis, click the Individual link: 
• In the Metrics section, click the Metric 

Summary, Set vs Individual or Metric 
Trends links; an error message is displayed 
on the page. 

• In the Analysis section, click Profiler. In the 
Profiler Page, the Metric Summary, Set vs 
Individual and Metric Trends links are not 
displayed. 

 
App Foundation 
This set contains rights to allow users to access different menus or sections in 
Dashboard Manager, Set Analysis, Process Analysis or Predictive Analysis. 
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NOTE The following rights have been introduced in BusinessObjects XI Release 2 SP2:   

• Access to system setup Repository and System User tabs 

• Access to system setup Universes and Dimensions tabs 

• Access to setup Time Config tab 

• Access to setup Parameters tab, 

• Access to setup Tools tab 

• Access to setup Control Charts tab. 

 

App Foundation 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to Metric 
Definition     

In Dashboard Manager, allows you to 
define metrics and metric trees. 

Depending on the actions to perform, 
the following Performance 
Management rights are also needed to 
work with metrics : 
• Configuration/Edit metric 
• Configuration/Define Sliced 

Metrics - Ability to select a 
dimension when creating a 
metric     

• Configuration/Refresh or Purge 
Metrics 

Click the Dashboard Manager tab and the 
Metrics or Metric Tree link; an error message 
is displayed. 

 

 

 

Access to Lists 
Menu     

In Set Analysis, allows you to define 
list for Set Analysis to export 
data/metadata.  

The list must first have been defined. 

Click the Set Analysis tab and the Export List 
link; an error message is displayed. 

To define a list, in Performance 
Management’s main toolbar, click the Setup 
button > Parameters tab > Lists link. 

Access to Rules 
Menu     

In Dashboard Manager, allows you to 
access Rules page. For certain actions, 
additional Performance Management 
rights must also be granted: 

• Rule/View Public Rules right to 
see public rules 

• Rules/Edit Public Rules to create 
public rules 

• Rules/Edit Private Rules to 
create private rules 

Click the Dashboard Manager tab and click 
the Rules link; an error message is displayed. 
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App Foundation 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to Schedule 
Menu   

 

In Dashboard Manager, allows you to 
schedule Metrics, Sets, Control 
Charts, Analytics, Models. 

The Configuration/Edit Schedule - 
Access to the scheduler menu right 
must also be granted to use the 
schedule features. 

To allow users to create a schedule, 
the Administrator must first 
configure the Scheduler and provide 
the server credentials to use to run a 
schedule on the server.  

In CMC, select Home > Objects > 
Object settings button > Program 
Objects tab > Run scripts/Binaries 
check box. Select also the Schedule 
with the following operating system 
credentials option and provide the 
credentials of the account to use to 
run schedules. This account must be 
defined in the machine where the 
release is installed. 

Click the Dashboard Manager tab and then 
the Scheduler link; an error message is 
displayed. 

 

Analytics Catalog     In Dashboard Manager, in 
Customization mode it allows you to 
drag and drop the analytic templates 
from the catalog and edit them within 
corporate or personal dashboard.  

Only analytics corresponding to 
functional areas he has access can be 
used. 

NOTE: Even if it is denied, the user is able to 
use an analytics template from the catalog. 
This issue has been logged under 
ADAPT00797017. 

Access to Sets 
Menu     

Allows you to use Set Analysis. Click the Set Analysis tab and then the Sets 
link; an error message is displayed. 
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App Foundation 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to Control 
Charts     

In Process Analysis, allows you to 
access the control charts page and 
view existing control charts.  A 
control chart is a Process Analysis 
analytics used to plot the variation in 
the outcome of a business process 
over a period of time. A control chart 
includes upper and lower limits that 
show the expected variation in the 
process and a center line that shows 
the mean value of the points in the 
chart. 

To create, modify, delete and refresh 
control charts, additional 
Performance Management rights 
must also be granted: 
• Configuration/Edit Control 

Charts  

• Configuration/Refresh Control 
Charts  

Click the Process Analysis tab and then the 
Control Charts link; an error message is 
displayed. 

Access to 
Population 
Definition     

 

In Predictive Analysis, allows you to 
access population page and view 
existing populations. A population is 
a named query that defines a group of 
interest. 

To create, modify, delete and refresh 
populations the Configuration/Edit 
Populations - Controls right must 
also be granted. 

Click the Predictive Analysis tab and then the 
Populations link; an error message is 
displayed. 

 

Access to Derived 
Variables     

In Predictive Analysis, allows you to 
access the Derived Variables page 
and see their definitions. Derived 
variables are user-defined data 
elements that are derived from 
universe objects and/or set 
membership. 

To create, modify, delete and refresh 
derived variables the 
Configuration/Edit Derived 
Variables - Controls the ability to 
create, edit, or remove derived 
variables right must also be granted. 

Click the Predictive Analysis tab, click the 
Derived Variables link; an error message is 
displayed. 
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App Foundation 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to Model 
Definition     

In Predictive Analysis, allows you to 
access the Models page and see the 
existing models. A model is a user-
specified configuration of the 
predictive calculation engine. To set 
up a model, the user selects 
influences, goals, and the population 
within which relationships are 
quantified. 

To create, modify, delete or refresh 
models the following Perfmormance 
Management rights must also be 
granted:  
• Configuration/Edit Models - 

Controls the ability to create, 
edit, or remove models  

• Configuration/Refresh Statistics 
or Regenerate Model  

Click the Predictive Analysis tab and then the 
Models link; an error message is displayed. 

Access to Create 
New Analytic 
Menu     

In Dashboard Manager, allows you to 
create a new analytic.  
 

Select the Dashboard Manager tab, click the 
New Analytic link;  an error message is 
displayed in the panel. 

 

Access to Analytic 
Services     

 

In Dashboard Manager, in 
Customization mode, allows you to 
drag and drop the analytic services 
and edit them within corporate or 
personal dashboard.  

Only analytics corresponding to 
functional areas he has access can be 
used. 

Open a dashboard. Click the Customize link 
in its top right corner to modify it. In the 
Analytics tree displayed in the left panel, the  
Analytics Services folder is not displayed. 

NOTE: Even if it is denied, the user is able to 
use analytics services. This issue has been 
logged under ADAPT00797017. 

 

Predictive Analytic 
Service     

Deprecated N/A 

Access to 
Application Builder  

In Dashboard Manager, allows you to 
access Dashboard Builder to 
administrate dashboards and design 
dashboard’s menus. 

The Add objects to the folder right 
must also be granted for a dashboard 
to add a menu in this dashboard.  

Click the Dashboard Manager tab, click the 
Dashboard Builder link; an error message is 
displayed. 
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App Foundation 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to system 
setup Repository 
and System User 
tabs     

Allows you to deploy the system 
tables and define the System User  for 
the application engines. 

To perform these tasks, the Services 
Bar/Access to System Setup right 
must also be granted. 

In the main toolbar, click the Setup button, 
click the System Setup tab; the Repository 
and System User links are not displayed. 

If this right and the Access to system setup 
Universes and Dimensions tabs right are 
denied, the full System Setup menu is not 
displayed. 

NOTE: This right is not working properly in 
BusinessObjects XI Release 2 SP2. When this 
right is denied, you can still be enter the 
Repository Setup page when you select the 
System Setup tab. The submenu Repository 
Setup menu is not displayed, but the default 
page is set to the Repository tab and will be 
opened by default. When security is applied 
on this menu, the default menu should be set 
to universes or presenting a blank screen. 

Access to system 
setup Universes 
and Dimensions 
tabs     

Allows you to define and push 
multiple metrics universes to the 
repository and to nominate the 
dimensions for sliced analysis. 

To perform these tasks, the Services 
Bar/Access to System Setup right 
must also be granted. 

In the main toolbar click the Setup button, 
click the System Setup tab; the Universes and 
Dimensions links are not displayed. 

If this right and the Access to system setup 
Repository and System User tabs right are 
denied, the full System Setup menu is not 
displayed. 

Access to setup 
Time Config tab     

Allows you to define the Calendar 
and Period properties that support 
time-based analysis 

To perform these tasks, the Services 
Bar/Access to System Setup right 
must also be granted. 

In the main toolbar click the Setup button; the 
Time Config tab is not displayed. 

Access to setup 
Parameters tab     

Allows you to specify the parameters 
necessary for the full functioning of 
the application. 

To perform these tasks, the Services 
Bar/Access to System Setup right 
must also be granted. 

In the main toolbar, click the Setup button; 
the Parameters tab is not displayed. 

Access to setup 
Tools tab     

Allows you to check integrity and 
cleanup application objects. 

To perform these tasks, the Services 
Bar/Access to System Setup right 
must also be granted. 

In the main toolbar, click the Setup button; 
the Tools tab is not displayed. 
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App Foundation 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to setup 
Control Charts tab   

Allows you to create Sampling, 
Alarms and Filters, which are used to 
create a control chart.  Sampling is 
mandatory to create control charts. 

To perform these tasks, the Services 
Bar/Access to System Setup right 
must also be granted. 

In the main toolbar, click the Setup button: 
the Control Charts tab is not displayed. 

Configuration 
This set contains rights to allow users to access different menus or sections in 
Dashboard Manager, Set Analysis, Process Analysis or Predictive Analysis. 

Configuration 
Right 

Description Impact in Performance Management if this 
right is denied 

Customize Module 
Page     

In Dashboard Manager, allows you 
to design dashboards, add analytics 
to dashboards... The Edit objects 
right must also be granted for the 
dashboard to edit. 

Open a dashboard; the Customize link is not 
displayed in the dashboard’s top right corner. 

Schedule Sets 
Refresh     

In Dashboard Manager, allows you 
to create scheduled tasks for Set 
Refresh. 

In the Dashboard Manager tab, click the 
Scheduler link, then select Set Refresh in the 
Add menu. The Schedule option is not 
available.  
NOTE: You are not able to create scheduled 
tasks even when this right is granted. This issue 
has been logged under ADAPT00799955. 

Edit Metric     In Dashboard Manager, allows you 
to create, modify and delete 
metrics.  

To perform these tasks, the App 
Foundation/Access to Metric 
Definition right must also be 
granted. 

In the Dashboard Manager tab, click the 
Metrics link. Select a metric, the metric 
definition is disabled 

Define Sliced 
Metrics - Ability to 
select a dimension 
when creating a 
metric     

In Dashboard Manager, allows you 
to select a dimension when creating 
of metric. 

The right Access to Metric 
Definition must also be granted to 
run this action. 

In the Dashboard Manager tab, click the 
Metrics link, then the Add button. Select the  
New Metric… or New Manual Entry Metric 
options in the scroll-down menu. In the Create 
Metric window that pops up, the Select a 
dimension scroll-down list is not displayed. 
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Configuration 
Right 

Description Impact in Performance Management if this 
right is denied 

Edit Schedule - 
Access to the 
scheduler menu     

In Dashboard Manager, allows you 
to edit schedule for Metrics, Sets, 
Control Charts, Analytics, Models 

The App Foundation/Access to 
Schedule Menu right must also be 
granted. 

  

Click the Dashboard Manager tab, then the 
Scheduler link; an error message box appears. 
Click the OK button and in the Scheduler page 
the Add, Edit, Delete… and History… buttons 
are not displayed. 

NOTE: You are not able to create scheduled 
tasks even when this right is granted. This has 
issue been logged under ADAPT00799955. 

Customize My 
Dashboards     

In Dashboard Manager, allows you 
to configure the My Dashboards 
space: adding pages, moving, 
creating and customizing them. 

Click My Dashboards: 

• In the My Dashboards Information Page, 
the Add link is disabled. 

• Select one page in My Dashboards. The <, 
>, Add a page, Delete this page and 
Customize links are not displayed. 

Edit Documents - 
Ability to 
add/edit/delete a 
Web Intelligence 
document     

In Dashboard Manager, allows you 
to access the query panel to create 
or edit a Web Intelligence 
document on the fly. 

Open a dashboard. Click the Customize link in 
its top right corner to modify it. In the Analytics 
tree displayed in the left panel, open the List of 
Analytics folder and select the Query Panel 
analytic. The Query Panel appears in the right 
frame with an error message displayed, 
preventing you from using it. 

Edit Control Charts   In Process Analysis, allows you to 
create, delete and modify Control 
Charts. 

The right App Foundation/Access 
to Control Charts must also be 
granted to run this action. 

Click the Process Analysis tab and then the 
Control Charts link. The existing Control 
Charts are displayed but the Add, Delete and 
Edit buttons not displayed.  

 

Refresh Control 
Charts     

In Process Analysis, allows you to 
refresh and purge control charts. 

The right App Foundation/Access 
to Control Charts must also be 
granted to run this action. 

Click the Process Analysis tab and then the 
Control Charts link; the Refresh and Purge 
buttons are not displayed. 

Edit Populations - 
Controls the ability 
to create, edit, or 
remove 
populations     

In Predictive Analysis, allows you 
to create, modify and delete 
populations 

The right App Foundation/Access 
to Population Definition must also 
be granted to run this action. 

Click the Predictive Analysis tab and then the 
Populations link; the Add, Delete and Edit 
buttons are disabled.  
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Configuration 
Right 

Description Impact in Performance Management if this 
right is denied 

Edit Derived 
Variables - Controls 
the ability to create, 
edit, or remove 
derived variables     

In Predictive Analysis, allows you 
to create, modify and delete derived 
variables based on universe objects. 

The right App Foundation/Access 
to Derived Variables must also be 
granted to run this action. 

Click the Predictive Analysis tab and then the 
Derived Variables link: 
• Click the Add button and New Derived 

Variable is not displayed in the scroll-down 
menu. 

• Select a derived variable in the list; the 
Remove and Edit buttons are disabled. 

Edit Models - 
Controls the ability 
to create, edit, 
copy, or remove 
models     

In Predictive Analysis, allows you 
to create, modify and delete 
models. 

The right App Foundation/Access 
to Mode Definition must also be 
granted to run this action. 

Click the Predictive Analysis tab and then the 
Models link; the Add, Remove, Copy and Edit 
buttons are disabled. 

Edit Data Mining 
Metrics - Controls 
the ability to create, 
edit, or remove 
data mining 
metrics     

In Predictive Analysis, allows you 
to create metrics based on the 
existing models 

Select the Dashboard Manager or the 
Predictive Analysis tab. Click the Metrics link:  
• Click the Add button; the New Model-

based metric choice is not displayed in the 
scroll-down menu. 

• The A new Model based Metric link is not 
displayed. 

Edit Binning - 
Controls the ability 
to create, edit, or 
remove bins for 
predictive analysis    

In Predictive Analysis, allows you 
to create, modify and delete binning 
based on the universe objects. 

The right App Foundation/Access 
to Derived Variables must also be 
granted to run this action. 

Click the Predictive Analysis tab and then the 
Derived Variables link: 
• Click the Add button; the New Binning 

choice is not displayed in the scroll-down 
menu. 

• Select a binning in the list. The Remove and 
Edit buttons are disabled. 

Refresh Statistics or 
Regenerate Model     

In Predictive Analysis, allows you 
to refresh or regenerate an existing 
model. 

Click the Predictive Analysis tab and then the 
Models link; the Refresh Statistics only and 
Regenerate buttons are disabled. 

Refresh or Purge 
Metrics     

Allows you to purge or refresh 
metrics. If this right is denied, the 
user is not able to work on 
refreshed data.  

The right App Foundation/Access 
to Metric Definition must also be 
granted to run this action from the 
portal. Although if the refresh or 
purge is run by schedule,  the 
Access to Metric Definition right is 
not needed.  

Access the Metrics definition panel through the 
Metrics link in Dashboard Manager or 
Predictive Analysis tab; the Refresh and Purge 
buttons are not displayed. 
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Configuration 
Right 

Description Impact in Performance Management if this 
right is denied 

Preview Analytics     Allows you to preview analytics 
that have multiple viewer options, 
such as Metric tree or Membership 
analytics.  

In preview, the user can see a static 
view but cannot refresh the 
analytic. 

When an analytic is displayed, the Preview link 
is not displayed in its toolbar (in the top right). 

 

Send email - 
Controls the ability 
to email an analytic   

In Dashboard Manager, allows you 
to email analytics. 

When an analytic is displayed, the Email link is 
not displayed in its toolbar (in the top right). 

 
Rules 
This set of rights is dedicated to Rules that can be defined in Dashboard 
Manager.     

NOTES • When creating the rule, no right prevents the user from adding the refresh a control 
chart or refresh a set actions in the rule. Nevertheless, the action themselves can 
be denied by denying the Configuration/Refresh Control Charts and 
Configuration/Schedule Set Refresh rights. 

• If all actions are disabled, user can still create rules, but as they contain no actions, 
they are useless. 

 

Rules Right Description Impact in Performance Management if this right 
is denied 

Actions - Raise an 
Alert 

Actions - Send an 
Email 

Actions - Define a 
List 

Actions - Generate an 
Event 

Actions - Refresh a 
Report 

Actions - Generate a 
URL 

Actions - Refresh 
Metrics 

Actions - Launch an 
Application 

In Dashboard Manager, allows 
you to select the raise an alert 
(or send an email, or define a 
list, …) action. This is for 
defining the actions to be run 
when an event attached to a 
Business Rules meets some 
conditions.  

To edit the action of a rule, the 
following Performance 
Management rights must also 
be granted:  

• Rules/Edit Public Rules for 
a public rule 

• Rules/Edit Private Rules 
for a private rule 

• App Foundation/Access to 

Click the Dashboard Manager tab, then the Rules 
link. Select a Business Rules in the list. Click 
Actions or click Edit and in the Rule Edition pop-
up window, click Actions. 

In the Rules Actions window, the appropriate 
action is not available. 

 

11/14/2007 9:26 AM Copyright © 2007 Business Objects. All rights reserved. Page 46 
 

boe_xi_r2_sp2_cmc_rights_descriptions_and_impact_on_applications.pdf 



BusinessObjects Enterprise XI Release 2 SP2 CMC Rights Descriptions and Their Impact on Different Applications 

Rules Right Description Impact in Performance Management if this right 
is denied 

Actions - Execute 
SQL 

Rules Menu.  

View Public Rules     In Dashboard Manager, allows 
you to view all public rules, 
even the ones created by other 
users.  

The right App 
Foundation/Access to Rules 
Menu must also be granted to 
run this action. 

In Performance Management, click the 
Dashboard Manager tab, then the Rules link. 

In the Available Business Rules page, the public 
rules are not displayed. 

NOTE: Even if you are granted this right, if you 
do not have permission to any of the Actions 
specified in the Rule, then the whole rule will be 
denied to you even if it is a public rule. This issue 
has been logged under ADAPT00795647. 

Edit Public Rules  

 

 

 

 

 
 

In Dashboard Manager, allows 
you to create, modify and 
delete public (or 
private/personal) rules.  
To run this action the App 
Foundation/Access to Rules 
Menu right must also be 
granted. 
 

Edit Private Rules  

In Performance Management, click the 
Dashboard Manager tab, then the Rules link. In 
the Available Business Rules page, select a 
public (or private/personal) rule:  

• The Remove, Edit, Copy, Events, Conditions 
and Actions links are unavailable.  

• Select the event defined for the rule; the Alert 
definition window does not display. 

• Select the condition defined for the rule: the 
Condition Formula Editor window does not 
display. 

• Select the action defined for the rule: the 
Rules Actions window does not display. 

• Double-click this rule, in the Rule Edition 
pop-up window, for Scope parameter, the 
Public option (public rule) or Private option 
(private/personal rule) is not available. 

Edit Private Folders 

Edit Public Folders   

In Dashboard Manager, allows 
you to create, modify and 
delete private (or public) 
folders used by rules. 

 

Click the Dashboard Manager tab, the Rules link, 
then the Folders button. The Rule Folders 
window appears:  

• Select a private (or public) rule; the Edit and 
Delete buttons are disabled 

• Click the Add button. In the new window that 
pops up, the Private (or Public) option is 
notavailable in the scroll-down list. 

 

Services Bar 
The Services Bar set contains rights that control icons and links in the toolbar to 
access some areas in all of Performance Management.   
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Services Bar Right Description Impact if this right is denied 

Access to 
Performance 
Management     

Allows you to use Performance 
Management. The Performance 
Management right Log on to 
Performance Management and 
view this object in the CMC 
must also be granted. 

The Performance Management icon is not 
displayed in the InfoView main toolbar. 

 

Options     Allows you to change 
Performance Management 
preferences in InfoView. 

In the InfoView Preferences screen, the 
Performance Management tab is not displayed. 

Access to My 
Dashboards     

Allows you to use My 
Dashboards to manage its own 
dashboards. 

Go to Performance Management. In the main 
toolbar, the My Dashboard button is not 
displayed. 

Access to System 
Setup 

Allows you to administrate and 
set Performance Management 
parameters. 

Go to Performance Management. In the main 
toolbar, the Setup button is not displayed. 

 

Strategy Builder Rights 
This application is related to Performance Management. Two rights sets exist 
for this application:   

• SBPerformanceManagement for goals management  

• SBStrategyBuilder for rights related to Strategy Builder. 

With the Strategy Builder application being located in the Performance 
Management application you need additional Performance Management rights 
to access it:  

• Use Performance Management 

• Services Bar/Access to Performance Management 

SBPerformanceManagement 
This set of rights is dedicated to Goals Management. 

 

SBPerformanceManagement 
Right 

Description Impact in Performance Management if this 
right is denied 

Create, Modify, or Delete Goals   In Performance Manager, 
allows you to add, edit or 
remove goals. 

Click the Performance Manager tab, and 
then the Goals Management link: the Add, 
Remove, Edit and Copy links are disabled.  

View Goals     Allows you to see goals in 
analytics containing goals. 

 

In a dashboard, analytics containing goals 
are not displayed; a blank area containing 
an error message is displayed instead. 
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SBPerformanceManagement 
Right 

Description Impact in Performance Management if this 
right is denied 

Access to Goal Management     In Performance Manager, 
allows you to see goals in 
Goal Management list. 

Click the Performance Manager tab and 
then the Goal Management link. No goal is 
displayed in the list of goals. 

Publish Goals   In Performance Manager, 
allows you to publish goals.  

Click the Performance Manager tab, and 
then the Goals Management link. The 
Publish… link is disabled. 

 
SBStrategyBuilder 
This set of rights is dedicated to features in Strategy Builder. 

SBStrategyBuilder Description Impact in Performance Management if this right 
is disabled 

Access to Strategy 
Builder     

In Performance Manager, 
allows you to use Strategy 
Builder. 

The Strategy Builder link is not displayed in the 
Performance Management application. 

Create, Modify, or 
Delete Roles  

In Strategy Builder, allows 
you to administrate roles 
used to publish the 
goal/metric to the specific 
audience 

In Performance Manager tab, click the Strategy 
Builder link. The Strategy Builder window is 
opened. In the Getting Started section, the New 
Role link is not displayed. 

Create, Modify, or 
Delete Strategies     

In Strategy Builder, allows 
you to create a strategy with 
which roles, published goals 
and published metrics are 
associated. 
Without a strategy, it is not 
possible to publish the goals 
and the metrics. 

In Performance Manager tab, click the Strategy 
Builder link. The Strategy Builder window is 
opened. In the Getting Started section, the New 
Strategy link is not displayed. 

 

Object and Objects Folder Rights 

Folder Rights 
Folders can contain different types of objects such as Web Intelligence, Desktop 
Intelligence, Crystal Reports documents and text files. Different rights can be 
applied to folders and these objects: 

• Some rights common to all objects. These rights are basic rights enforced 
by the framework. Some rights are not applicable to folders, but are 
inherited by objects belonging to this folder and are applicable to these 
objects. These rights are displayed in the CMC in the General rights 
category (see also General compared to custom rights, on page 3). 

• Some rights specific to the object type. The different objects types that have 
specific rights sets are Desktop Intelligence, Desktop Intelligence 
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Template, Desktop Intelligence Add-in, Web Intelligence, Crystal Reports 
and Text. Because of the way objects are stored in the CMS, all the rights of 
these categories can be applied to any object. But in practice, only the 
rights corresponding to the object type apply. For example, only the 
Desktop Intelligence set of rights makes sense for a Desktop Intelligence 
document. These rights that do not apply to folders but will be inherited 
by objects contained in this folder.  

The following table describes only the General rights for a folder. Other rights 
do not apply to folders and are only inherited by objects contained in this 
folder, unless the inheritance has been broken. 

Next sections describe the meaning of the General rights and of the Custom 
rights that can apply to different objects. 

General 
Right 

Description Impact if this right is denied 

Add objects 
to the folder 

Allows you to create, 
copy, move or save an 
object or a folder in this 
folder. Depending on the 
action, additional rights 
are needed on the object 
(Edit objects, Delete 
objects, Copy objects to 
another folder) or on the 
application (Send 
Documents to 
Repository for Desktop 
Intelligence). 

Any application: The application does not allow you to copy, to 
move or to save an object or report in this folder. Depending on 
the application, it can be an error message or a button disabled. 
For  example:  

InfoView: In the left panel navigation tree, select this folder. On 
the New menu, select the Folder command. Type a folder name, 
click the OK button; an error message is displayed. 

CMC: 

• In this folder’s Objects tab, the New object… button is 
disabled. 

• In this folder’s Subfolders tab, the New Folder button is 
disabled. 

View 
objects* 

Allows you to view this 
folder. 

See View Objects Right, on page 6.  

Edit objects* Allows you to edit the 
folder’s properties 
(Name, Description, 
Keywords). 

CMC: 

• In the folder’s Properties tab, content is disabled; the Update 
and Reset buttons are disabled.  

• In the Subfolders tab of this folder’s parent, select the folder’s 
check box. Click the Copy/Move… button and a warning 
message is displayed. Click the OK button. In the Copy/Move 
Folder page that appears, the Move to radio button option is 
disabled and cannot be selected. 

InfoView: 

In the folder navigation tree panel, select this folder.  

• Click the Properties button: the Properties page appears but 
cannot be edited. 

• Click on the Move button. The Move page appears. Select a 
destination folder and click the OK button; an error message 
is displayed. 
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General 
Right 

Description Impact if this right is denied 

Modify the 
rights users 
have to 
objects* 

See Modify the rights 
users have to objects, on 
page 4. 

See Modify the rights users have to objects, on page 4. 

Schedule 
the 
document 
to run 

N/A for a folder. N/A for a folder, but this right is inherited by objects belonging to 
this folder. 

Delete 
objects* 

Allows you to delete the 
folder. This right is also 
needed to move the 
folder, as well as the 
Edit objects right. 

CMC:  

In the Subfolders tab of this folder’s parent, click the check box 
near the folder name to select it: 

• Click the Copy/Move… button; a warning message box 
appears. Click the OK button. In the Copy/Move Folder page 
that appears, the Move to radio button option is unavailable. 

• Click the Delete button;  an error message box appears. 

InfoView: In the Category tree, select this category, click the 
Delete icon; an error message box appears. 

Define 
server 
groups to 
process jobs 

Delete 
instances* 

N/A for a folder. N/A for a folder, but this right is inherited by objects belonging to 
this folder. 

Copy 
objects to 
another 
folder 

Allows you to copy this 
folder and its content 
into another folder. If 
this right is denied for 
one object or one 
subfolder of this folder, 
no content is copied at 
all.  

InfoView: In the folder tree panel, select this folder or a folder 
containing this folder. Click the Copy button. The Copy page 
appears. Select a destination folder, click the OK button; an error 
message is displayed. 

CMC: In the Subfolders tab of this folder’s parent, click the check 
box near the folder name to select it. Click the Copy/Move… 
button; a warning message box appears. Click the OK button. In 
the Copy/Move Folder page that appears, the Copy to radio 
button option is disabled. 

Schedule to 
destinations 

View 
document 
instances* 

Pause and 
Resume 
document 
instances* 

N/A for a folder. N/A for a folder, but these rights are inherited by objects 
belonging to this folder. 
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General 
Right 

Description Impact if this right is denied 

Securely 
modify 
rights users 
have to 
objects. * 

See Modify the rights 
users have to objects, on 
page 4. 

See Modify the rights users have to objects, on page 4. 

Reschedule 
instances* 

Schedule on 
behalf of 
other users 

N/A for a folder. N/A for a folder, but these rights are inherited by objects 
belonging to this folder. 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

Web Intelligence Document Rights 
Web Intelligence documents are based on one or several universes. Web 
Intelligence documents can be stored only in the CMS.  

General Right Description  Impact if this right is denied 

Add objects to the 
folder 

N/A N/A 

View objects* Allows you to view the 
document. 

See View Objects Right, on page 6. 
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General Right Description  Impact if this right is denied 

Edit objects* Allows you to modify the 
document content and its 
properties (name, description, 
categories…).  
See also Edit Objects Right on 
page 7. 

Web Intelligence Interactive Viewer: In the 
Document menu, the Edit command is not 
available. 
Web Intelligence Java Report Panel: Make some 
changes in the document. Click the Save icon, 
choose Save As... Select the same folder and name 
and click OK. After the confirmation message, an 
error message box appears.  
InfoView: In any list containing this document, 
click this document’s Properties link. The 
Properties page appears for this document but its 
content is disabled. 

CMC: Select this document to open its panel. 
• Click the Properties tab; its content is disabled 

(input fields cannot be edited and the Update 
and Reset buttons are unavailable).  

• Click the Process tab; its content is disabled 
(input fields cannot be edited and the Update 
and Reset buttons are unavailable).  

• Click the Categories tab; the Assign Category 
button is disabled. 

Modify the rights 
users have to objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Schedule the 
document to run 

Allows you to schedule this 
document. 

InfoView: In any list containing this document, the 
Schedule link is not displayed for this document. 
CMC: Select this document to open its panel. Click 
the Schedule tab; the Schedule button is disabled. 

Delete objects* Allows you to delete this 
document. 

CMC or InfoView: In any list containing this 
document, select the check box for this document. 
Click the Delete button; an error message box 
appears. 

Define server groups 
to process jobs 

Allows you to define process 
group to use to process this 
document schedule. The Edit 
objects right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s Schedule link. The Schedule 
page appears for this document. Modify the 
parameters under the Server Group section and 
click the Update button;  an error message is 
displayed. 

CMC: Select this document to open its panel. Click 
the Process tab; its content is disabled (input fields 
cannot be edited and the Update and Reset buttons 
are unavailable).   
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General Right Description  Impact if this right is denied 

Delete instances* Allows you to delete this 
document’s instances. 

InfoView: In any list containing this document, 
click this document’s History link. The list of 
instances for this document is displayed. Select 
some instances by clicking the check box near their 
names. Click the Delete button; an error message is 
displayed. 

CMC: Select this document to open its panel. Click 
the History tab. Select some instances, click the 
Delete button; an error message box appears. 

Copy objects to 
another folder 

Allows you to create a copy 
of this document in another 
folder in the CMS. 

Interactive Viewer: The Document > Save as 
command is not displayed. 

HTML Viewer: The Document > Save as command 
is not displayed. 

InfoView: In any list containing this document, 
select this document by clicking the check box near 
its name. On the Organize menu, select the Copy to 
New Folder… command. Select a destination folder 
and click the OK button; an error message is 
displayed. 

CMC: Select the folder containing this document to 
open its panel. Click the Objects tab. Select this 
document, click the Copy/Move/Shortcut… button; 
an error message box appears. 

Schedule to 
destinations 

Allows you to change 
thisdocument’s schedule 
destinations (Default, Email, 
Inbox).  

The following rights must 
also be granted:  

• Schedule the document 
to run at document level 

• Add objects to the folder 
for the recipient inbox 
folders if the destinations 
contain inboxes.  

InfoView: In any list containing this document, 
click this document’s Schedule link. The Schedule 
page appears for this document but the Destination 
section is not displayed. 

CMC: Select this document to open its panel. Click 
the Schedule tab, then the Destination sub-tab; its 
content is disabled (input fields cannot be edited 
and the Update and Reset buttons are unavailable). 

 

View document 
instances* 

Allows you to view the 
instances of this document. 

InfoView: In any list containing this document, the 
History link is not displayed for this document. 

CMC: Select this document to open its panel. Click 
the History tab; the list of instances is empty. 
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General Right Description  Impact if this right is denied 

Pause and Resume 
document instances* 

Allows you to pause or 
resume a schedule (even the 
ones that have not been 
created by the user). 
The View document 
instances right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s History link. The list of 
instances for this document is displayed. Select 
some instances by clicking the check box near their 
names. Click the Pause or Resume button; an error 
message is displayed.  

CMC: Select this document to open its panel. Click 
the History tab. Select some instances and click the 
Pause or Resume button; an error message box 
appears. 

Securely modify 
rights users have to 
objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Reschedule 
instances* 

Allows you to reschedule an 
instance of this document.  
The View document 
instances right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s History link. The list of 
instances for this document is displayed but the 
Reschedule link is not available in the Reschedule 
column. 
CMC: N/A since it is not possible to reschedule an 
instance in the CMC. 

Schedule on behalf of 
other users 

Allows you to schedule this 
document for another user or 
group. The schedule runs 
with the credential of the 
other user or group who 
becomes the owner of the 
new instance. The result is the 
same as if the other user or 
group schedules the report 
himself.  

The Schedule the document 
to run right must also be 
granted. 

InfoView: N/A. It is not possible to schedule on 
behalf of other users in InfoView. 

CMC: Select this document to open its panel. Click 
the Schedule tab, then the Schedule For sub-tab. 
Change the list of users or groups to schedule this 
document for and click the Update button;  an error 
message is displayed. 

 

 

  *: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 
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Custom Right Description  Impact if this right is denied 

Refresh the report's 
data 

Allows you to refresh the 
data contained in this report. 
See also Refresh a Web 
Intelligence Document on 
page 88. 

Query HTML: In the Edit Query panel, click the 
Refresh button; an error message box appears. 
Java Report Panel: Click the Run Query button; an 
error message box appears. 
HTML Report Panel: Click the Run button; an error 
message box appears. 
Interactive Viewer: The Refresh Data button is not 
displayed. 
HTML Viewer: The Refresh Data button is not 
displayed. 

Edit Query Allows you to edit this 
report’s query. 

Query HTML: The Edit Query button is not 
displayed. 
Java Report Panel: The Edit Query button is 
disabled. 
HTML Report Panel: The Query and Query Filters 
tabs are not displayed. 

Refresh List of Values Allows you to refresh the list 
of values of this report, in 
both edit mode, when the 
user creates some prompt, or 
at refresh time, when the user 
must fill the prompts. 
The Use Lists of Values right 
must also be granted to 
refresh list of values.  

Java Report Panel: In edit mode, when defining 
default values for a prompt, in the List of Values 
windows, click the Refresh List button; an error 
message box appears. 
Query HTML: When defining default values for a 
prompt, in the List of Values windows, the Refresh 
Values button is not displayed. 
HTML Report Panel: N/A since it is not possible to 
list List of Values. 
Interactive Viewer: When refreshing the document, 
when prompts are displayed, the Refresh Values 
button is not displayed. 
HTML Viewer: The Refresh Values button is not 
displayed. 
Java Viewer: Click the Refresh List button; an error 
message box appears. 
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Custom Right Description  Impact if this right is denied 

Use Lists of Values Allows the use and refresh of 
lists of values in this 
document. 

Java Report Panel: In edit mode, before displaying 
prompts property window, an error message is 
displayed.  
In this window, click the Refresh List button; an 
error message box appears. 
Any access to display list of values or select list of 
values for a prompt displays an error window. 
Query HTML: When defining default values for a 
prompt, in the Prompt Properties windows, no list 
of values is displayed. 
HTML Report Panel: N/A since it is not possible to 
list List of Values. 
HTML Viewer & Interactive Viewer: Click the 
Refresh Data button; an error message box appears. 
Java Viewer: In the Prompts window, the List of 
Values is empty. Click the Refresh List button; an 
error message box appears. 

View SQL Allows you to view the SQL 
generated by the query and 
processed at refresh. 

Query HTML: Click the View SQL button; the SQL 
page is displayed without any SQL code inside. 
Java Report Panel: In the Edit Query panel, in the 
Query toolbar click the SQL button;  an error 
message box appears. 
HTML Report Panel: N/A since it is not possible to 
view the SQL code from HTML Report Panel. 

Export the report's 
data 

Allows you to export this 
document’s data to Excel, 
PDF or CSV formats. 
 

Java Report Panel (View): Click the Save button 
and then for Save to my computer as click PDF or 
Excel; an error message box appears. 
Interactive Viewer: Click the Document button ;the 
Save to my computer as… command is not 
displayed. 
HTML Viewer: Click the Document button; the 
Save to my computer as… command is not 
displayed. 

Download files 
associated with the 
object 

N/A 
 

N/A 

 

NOTE Depending on the way you edit the document, the display may be slightly different. For 
example:  

• On InfoView, click the Modifiy link for the document; the New document button is 
disabled 

• On InfoView, click the document to view it in the Web Intelligence Viewer. Then click 
the Edit button; the New Document button is enabled. 
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Desktop Intelligence Document Rights 
For Desktop Intelligence, rights exist both at the application level (see Desktop 
Intelligence Rights , on page 21) and at the document level. Nevertheless, 
rights at document level impact only InfoView, the HTML Viewer and the 
CMC since the Desktop Intelligence application itself does not enforce 
document rights.  

Once a document is opened in the Desktop Intelligence, only the Desktop 
Intelligence application rights are applied, the document’s rights themselves 
are not applied. Thus the View SQL right at document level is meaningless 
since it is not taken into account by Desktop Intelligence and it is not possible 
to view SQL in the HTML Viewer. 

So, if a right is denied at document level, a user can bypass this denied right 
just by downloading the document locally. To avoid this situation, 
administrators can do the following: 

• Deny the Retrieve documents right at application level to prevent the 
download of all documents 

• Deny the Download files associated with the object or Export the report's 
data  rights at the document level to prevent its download. 

NOTE Even if one of these rights at document level is denied, the user can download the 
document from InfoView. In Desktop Intelligence HTTP mode, it does not prevent the user 
from downloading the file. It is recommended to deny Retrieve documents at application 
level. This issue has been logged under ADAPT00825698. 

 
A Desktop Intelligence document saved locally outside the CMS is secured and 
can only be opened by the user who has saved it. If another user tries to open 
it, an error message is displayed, unless the document has been saved with the 
Save for all users option. A document saved without this option cannot be 
opened in the Standalone mode.  

One right exists both at application and document levels (document refresh). 
Nevertheless, it interacts only in the HTML Viewer since Desktop Intelligence 
does not take a document’s rights into consideration.  

General 
Right 

Description Impact if this right is denied 

Add objects 
to the folder 

N/A N/A 

View 
objects* 

Allows you to view 
this folder.  

 

See View Objects Right , on page 6. 
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General 
Right 

Description Impact if this right is denied 

Edit objects* Allows you to modify 
this document 
content and its 
properties (name, 
description, 
categories…).  

See also Edit Objects 
Right on page 7. 

HTML Viewer: Open this document; on the Document menu, the 
Edit and Save commands are not displayed. 

InfoView: In any list containing this document, click this document’s 
Properties link. The Properties page appears for this document but 
its content is disabled. 

CMC: Select this document to open its panel. 

• Click the Properties tab; its content is disabled (input fields 
cannot be edited and the Update and Reset buttons are 
unavailable).  

• Click the Process tab; its content is disabled (input fields cannot 
be edited and the Update and Reset buttons are unavailable).  

• Click the Categories tab; the Assign Category button is disabled.  

Modify the 
rights users 
have to 
objects* 

See Modify the rights 
users have to objects, 
on page 4. 

See Modify the rights users have to objects, on page 4. 

Schedule 
the 
document 
to run 

Allows you to 
schedule this 
document. 

InfoView: In any list containing this document, the Schedule link is 
not displayed for this document. 

CMC: Select this document to open its panel. Click the Schedule tab; 
the Schedule button is disabled. 

Delete 
objects* 

Allows you to delete 
this document. 

InfoView: In any list containing this document, select this document 
by clicking the check box near its name, click the Delete button; an 
error message box appears. 

CMC: In any list containing this document, select this document by 
clicking the check box near its name, click the Delete button; an error 
message box appears. 

Define 
server 
groups to 
process jobs 

Allows you to define 
process group to use 
to process this 
document schedule. 
The Edit objects right 
must also be granted.  

InfoView: In any list containing this document, click this document’s 
Schedule link. The Schedule page appears for this document. Modify 
the parameters under the Server Group section; click the Update 
button; an error message is displayed. 

CMC: Select this document to open its panel. Click the Process tab; 
its content is disabled (input fields cannot be edited and the Update 
and Reset buttons are unavailable).   

Delete 
instances* 

On the server, allows 
you to delete this 
document’s instances. 

The View document 
instances right must 
also be granted. 

InfoView: In any list containing this document, click this document’s 
History link. The list of instances for this document is displayed. 
Select some instances by clicking the check box near their names and 
click the Delete button; an error message is displayed. 

CMC: Select this document to open its panel. Click the History tab. 
Select some instances and click the Delete button; an error message 
box appears. 

Desktop Intelligence: N/A since it is not possible to delete 
document’s instances in Desktop Intelligence. 
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General 
Right 

Description Impact if this right is denied 

Copy 
objects to 
another 
folder 

Allows you to create 
a copy of this 
document in another 
folder in the CMS. 

HTML Viewer: On the Document menu, the Save and Save as 
commands are not displayed. 

NOTE: This right is not working properly in BusinessObjects XI 
Release 2 SP2: when this right is disabled, the Document > Edit 
command is not displayed, whereas it should be displayed. 

InfoView: In any list containing this document, select this document 
by clicking the check box near its name. On the Organize menu, 
select the Copy to New Folder… command. Select a destination 
folder and click the OK button; an error message is displayed. 

CMC: Select the folder containing this document to open its panel. 
Click the Objects tab. Select this document and click the 
Copy/Move/Shortcut… button; an error message box appears. 

Schedule to 
destinations 

Allows you to change 
thIS document’s 
schedule destinations 
(Default, Email, 
Inbox).  

The following rights 
must also be granted:  

• Schedule the 
document to run 
at document level 

• Add objects to 
the folder for the 
recipient inbox 
folders if the 
destinations 
contain inboxes.  

InfoView: In any list containing this document, click this document’s 
Schedule link. The Schedule page appears for this document; the 
Destination section is not displayed. 

CMC: Select this document to open its panel. Click the Schedule tab, 
then the Destination sub-tab; its content is disabled (input fields 
cannot be edited and the Update and Reset buttons are disabled). 

 

View 
document 
instances* 

Allows you to view 
this document’s 
instances. 

InfoView: In any list containing this document, the History link is 
not displayed for this document. 

CMC: Select this document to open its panel. Click the History tab; 
the list of instances is empty. 

Pause and 
Resume 
document 
instances* 

Allows you to pause 
or resume a schedule 
(even the ones that 
have not been created 
by the user). 

The View document 
instances right must 
also be granted. 

InfoView: In any list containing this document, click this document’s 
History link. The list of instances for this document is displayed. 
Select some instances by clicking the check box near their names and 
click the Pause or Resume button;  an error message is displayed.  

CMC: Select this document to open its panel. Click the History tab. 
Select some instances and click the Pause or Resume button; an error 
message box appears. 
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General 
Right 

Description Impact if this right is denied 

Securely 
modify 
rights users 
have to 
objects* 

See Modify the rights 
users have to objects, 
on page 4. 

See Modify the rights users have to objects, on page 4. 

Reschedule 
instances* 

Allows you to 
reschedule an 
instance of this 
document.  

The View document 
instances right must 
also be granted. 

InfoView: In any list containing this document, click this document’s 
History link. The list of instances for this document is displayed but 
the Reschedule link is not available in the Reschedule column. 

CMC: N/A since it is not possible to reschedule an instance in the 
CMC.  

Schedule on 
behalf of 
other users 

Allows you to 
schedule this 
document for another 
user or group. The 
schedule runs with 
the credential of the 
other user or group 
who becomes the 
owner of the new 
instance. The result is 
the same as if the 
other user or 
group schedules the 
report himself.  

The Schedule the 
document to run 
right must also be 
granted. 

InfoView: N/A. It is not possible to schedule on behalf of other users 
in InfoView. 

CMC: Select this document to open its panel. Click the Schedule tab, 
then the Schedule For sub-tab. Change the list of users or groups to 
schedule this document for and click the Update button; an error 
message is displayed. 

 

 

 

 *: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

Custom 
Right 

Description Impact if this right is denied 

Refresh the 
report's data 

 

Allows you to refresh 
this document from 
its Data Providers to 
update its content. 
See Refresh a 
Desktop Intelligence 
document on page 88. 

HTML Viewer: The Refresh button is not available. 

See also the description of the Refresh Desktop Intelligence   
Document right at the Desktop Intelligence application level 
(Desktop Intelligence Rights on page 21). 
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Custom 
Right 

Description Impact if this right is denied 

Refresh List 
of Values 

Allows you to refresh 
the list of values used 
in prompts. The Use 
List of Values right 
must also be granted 
to refresh the list of 
values.  

HTML Viewer: Open a document with a prompt. Click the Refresh 
button and the Prompts window appears; the Refresh Values button 
is not displayed. 

Use Lists of 
Values 

Allows the use and 
refresh of lists of 
values in the 
document 

HTML Viewer: Open a document with a prompt. Click the Refresh 
button and the Prompts window appears; the list of values and the 
Refresh Values button are not displayed. 

View SQL Allows you to view 
the SQL used for the 
Query. 

HTML Viewer: N/A 

Desktop Intelligence: This right is not taken into account.  

Export the 
report's data 

Allows you to export 
the document’s data. 
This right must also 
be granted with the 
Download files 
associated with the 
object right to allow 
the user to download 
the file in Desktop 
Intelligence. 

HTML Viewer: The Document > Save to my computer as menu and 
its commands (Excel, CSV, PDF) are not displayed. 

NOTE: This right is not working properly in BusinessObjects XI 
Release 2 SP2: even if this right is denied, the user can download the 
document from InfoView or from Desktop Intelligence. 

Download 
files 
associated 
with the 
object 

Allows you to 
retrieve this 
document from the 
CMS.  

The following rights 
must also be granted:   

• Export the 
report's data at 
document level. 

• Retrieve 
documents at 
application level. 

Desktop Intelligence (CMS or HTML mode):  Select File > Import 
From Repository… Select this document in the list and click the 
Retrieve button; an error message box appears. 
NOTE: This right is not working properly in BusinessObjects XI 
Release 2 SP2: even if this right is denied, the user can download the 
document from InfoView or from Desktop Intelligence HTTP mode. 

 

Crystal Reports Document Rights 
Crystal Reports rights are enforced only in the CMS. When a Crystal Reports 
document is downloaded locally on your hard disk, no more rights are 
enforced and the user can perform any operation on it.  

To avoid this, you can deny the Download files associated with the object at 
document level. This will prevent the user to download the Crystal Reports 
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document locally on the machine. This can also be prevented by denying the 
Export the report's data right, which also prevents the user from exporting the 
report data to XLS, PDF or CSV. 

General Right Description  Impact if this right is denied 

Add objects to the 
folder 

N/A N/A 

View objects* Allows you to view this 
document. 

See View Objects Right, on page 6. 

Edit objects* Allows you to modify this 
document content and its 
properties (name, description, 
categories…).  

See Edit Objects Right on 
page 7. 

Crystal Reports: 

When opening a report through the RAS SDK 
(ReportClientDocument object) in Java, COM or 
.NET, or Crystal Reports for .NET (ReportDocument 
object) , any SDK call to modify report objects or 
report properties will fail.  Note that setting 
database logon, parameter values, exporting and 
viewing only require viewing rights to succeed.  
Enforced at the SDK level. 

The Crystal Reports designer is able to open, edit 
and view the report. 

InfoView: In any list containing this document, 
click this document’s Properties link. The 
Properties page appears for this document but its 
content is disabled. 

CMC: Select this document to open its panel. 

• Click the Properties tab; its content is disabled 
(input fields cannot be edited and the Update 
and Reset buttons are unavailable).  

• Click the Process tab; its content is disabled 
(input fields cannot be edited and the Update 
and Reset buttons are unavailable).  

• Click the Categories tab; the Assign Category 
button is disabled. 

Modify the rights 
users have to objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Schedule the 
document to run 

Allows you to schedule this 
document. 

InfoView: In any list containing this document, the 
Schedule link is not displayed for this document. 
CMC: Select this document to open its panel. Click 
the Schedule tab; the Schedule button is disabled. 
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General Right Description  Impact if this right is denied 

Delete objects* Allows you to delete this 
document. 

InfoView: In any list containing this document, 
select this document by clicking the check box near 
its name and click the Delete button; an error 
message box appears. 
CMC: In any list containing this document, select 
this document by clicking the check box near its 
name and click the Delete button; an error message 
box appears. 

Define server groups 
to process jobs 

Allows you to define process 
group to use to process this 
document schedule. The Edit 
object right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s Schedule link. The Schedule 
page appears for this document. Modify the 
parameters under the Server Group section and 
click the Update button;  an error message is 
displayed. 
CMC: Select this document to open its panel. Click 
the Process tab; its content is disabled (input fields 
cannot be edited and the Update and Reset buttons 
are disabled).   

Delete instances* Allows you to delete this 
document’s instances. 

The View document 
instances right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s History link. The list of 
instances for this document is displayed. Select 
some instances by clicking the check box near their 
names. Click the Delete button; an error message is 
displayed. 

CMC: Select this document to open its panel. Click 
the History tab. Select some instances and click the 
Delete button; an error message box appears. 

Copy objects to 
another folder 

Allows you to create a copy 
of this document in another 
folder in the CMS. 

InfoView: In any list containing this document, 
select this document by clicking the check box near 
its name. On the Organize menu, select the Copy to 
New Folder… command. Select a destination folder 
and click the OK button; an error message is 
displayed. 
CMC: Select the folder containing this document to 
open its panel. Click the Objects tab. Select this 
document and click the Copy/Move/Shortcut… 
button; an error message box appears. 
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General Right Description  Impact if this right is denied 

Schedule to 
destinations 

Allows you to change this 
document’s schedule 
destinations (Default, Email, 
Inbox).  

The following rights must 
also be granted:  

• Schedule the document 
to run at document level 

• Add objects to the folder 
for the recipient inbox 
folders if the destinations 
contain inboxes.  

InfoView: In any list containing this document, 
click this document’s Schedule link. The Schedule 
page appears for this document; the Destination 
section is not displayed. 

CMC: Select this document to open its panel. Click 
the Schedule tab, then the Destination sub-tab; its 
content is disabled (input fields cannot be edited 
and the Update and Reset buttons are disabled). 

 

View document 
instances* 

Allows you to view the 
instances of this document. 

InfoView: In any list containing this document, the 
History link is not displayed for this document. 

CMC: Select this document to open its panel. Click 
the History tab; the list of instances is empty. 

Pause and Resume 
document instances* 

Allows you to pause or 
resume a schedule (even the 
ones that have not been 
created by the user). 

The View document 
instances right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s History link. The list of 
instances for this document is displayed. Select 
some instances by clicking the check box near their 
names. Click the Pause or Resume button; an error 
message is displayed.  

CMC: Select this document to open its panel. Click 
the History tab. Select some instances and click the 
Pause or Resume button; an error message is 
displayed. 

Securely modify 
rights users have to 
objects* 

See Securely Modify the 
rights users have to objects, 
on page 4. 

See Securely Modify the rights users have to objects, 
on page 4. 

Reschedule 
instances* 

Allows you to reschedule an 
instance of this document.  

The View document 
instances right must also be 
granted. 

InfoView: In any list containing this document, 
click this document’s History link. The list of 
instances for this document is displayed but the 
Reschedule link is not available in the Reschedule 
column. 

CMC: N/A since it is not possible to reschedule an 
instance in the CMC.  
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General Right Description  Impact if this right is denied 

Schedule on behalf of 
other users 

Allows you to schedule this 
document for another user or 
group. The schedule runs 
with the credential of the 
other user or group who 
becomes the owner of the 
new instance. The result is the 
same as if the other user or 
group schedules the report 
himself.  

The Schedule the document 
to run right must also be 
granted. 

InfoView: N/A. It is not possible to schedule on 
behalf of other users in InfoView. 

CMC: Select this document to open its panel. Click 
the Schedule tab, then the Schedule For sub-tab. 
Change the list of users or groups to schedule this 
document for and click the Update button;  an error 
message is displayed. 

 

 

 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

Custom Right Description  Impact if this right is denied 

Print the report’s data Allows you to print this 
report. 

Crystal Reports: Scheduling to printer will fail.  
This right only applies to scheduling, not printing 
from the viewers.  The technical reason is that 
printing from the viewers is exclusively a client-side 
action and does not access the CRPE engine to check 
rights.   

Refresh the report's 
data 

Allows you to refresh the 
data contained in this report. 

InfoView: In the list of reports, the link to view the 
report with live data will be disabled.  

Crystal Reports: When viewing the report with the 
DHTML, ActiveX or Java viewer, clicking the 
refresh button and causing a database refresh will 
fail.  Report scheduling and the Crystal Reports 
designer are not affected by this right. 

Export the report's 
data 

Allows you to export this 
document’s data to XLS, PDF 
or CSV formats. If the 
Download files associated 
with the object right is also 
granted, it also allows you to 
export this document in RPT 
format. 

Exporting the report from the viewer and RAS SDK 
will fail.  Report scheduling and the Crystal Reports 
designer are not affected by this right. 

Download files 
associated with the 
object 

Allows you to export this 
report to RPT format, or open 
through Crystal Reports 
Designer. 
The Export the report's data 
right needs also to be granted 
to export the report to RPT 
format.  

Exporting the report to rpt from the viewer, 
scheduling or SDK will fail.  Opening the report 
through the Crystal Reports designer (CRW) will 
fail.  Report scheduling and the Crystal Reports 
designer are not affected by this right. 
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Dashboard Rights  
Dashboard is the high-level component in Performance Management. It is 
made of analytics and/or reports to display to users: 

• Analytics can be located in the CMS or in the dashboard itself. In the first 
case, rights apply to these analytics. In the second case, no right apply to 
the analytics 

• Reports are located in the CMS. When the dashboard is opened, the 
reports contained in this dashboard are refreshed. 

In both cases, for analytics and reports located in the CMS, rights apply to 
these objects. When the dashboard is displayed, rights are computed for these 
analytics/reports in this report.  

• If you have the View objects right denied on the analytic, you will not be 
able to see the analytic.  

• If you have the View objects right denied on the report, you will not be 
able to see the report and an error message is displayed in the frame 
containing the document.  

• If you have the Refresh objects right denied on the report, an error 
message is displayed in the frame containing the document.  

Dashboard can be organized in menus, each menu can contain sub-menus, that 
are also located in CMS and on which rights can be applied. One menu can 
only belong to one menu or to one dashboard. The menu organization can be 
seen as a tree, with the dashboard at the root of the tree. 

A menu has the same set of rights as a Dashboard and can be seen as a sub-
dashboard. Rights that apply to this menu are the same that apply to the 
dashboard but their scope is limited to this menu and its sub-menu. If the 
View objects right is denied for a menu, then this menu is not displayed in the 
dashboard. 

General Right Description  Impact if this right is denied 

Add objects to the 
folder 

Allows you to add a menu in 
this dashboard.  
The user also needs the 
Access to Application 
Builder right to access the 
Application Builder where he 
can administrate dashboards 
and design dashboard’s 
menus.  
This right Add objects to the 
folder does not allow the user 
to add an analytic or any 
other document in this 
dashboard. 

Performance Management: Select the Dashboard 
Manager tab and then the Dashboard Builder link. 
Select this dashboard in the Dashboard Structure 
tree list. In the Add menu, select the New Menu 
command. A new menu appears below this 
dashboard. Click the Save button; an error message 
box appears. 
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General Right Description  Impact if this right is denied 

View objects* Allows you to view this 
dashboard. 

See View Objects Right, on page 6. 

Edit objects* Allows you to edit this 
document: document’s 
properties (name, description, 
categories…) and content. 
To edit this dashboard 
content, the user also needs 
the Performance 
Management’s Customize 
Module Page right 
This Edit objects right does 
not prevent the user from 
editing this dashboard’s 
menus. 
NOTE: The Edit objects right 
must also be granted to delete 
a dashboard. 
 

InfoView: 
• In the document list, click on this dashboard’s 

Properties link. The Properties page appears for 
this dashboard but its content cannot be edited. 

• Open this dashboard. The Customize link in not 
displayed in the top right of this dashboard. 

Performance Management: 
• Open a dashboard. The Customize link in not 

displayed in the top right of the dashboard. 

• Select the Dashboard Manager tab and then the 
Dashboard Builder link. Select this dashboard 
in the Dashboard Structure tree list.  
• The Customize the content and the layout 

of this page link is not displayed. 
• The Name text field is unavailable and 

cannot be edited.  
• The Select link near the Menu text box is 

not displayed.  
• In Advanced Parameters section, the Help 

URL text box is unavailable and cannot be 
edited. 

CMC: 
• In the dashboard Properties tab, content is 

unavailable and cannot be edited; the Update 
and Reset buttons are disabled.  

• In the document’s Categories tab, the Assign 
Categories button is disabled. 

Modify the rights 
users have to objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Schedule the 
document to run 

N/A N/A 
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General Right Description  Impact if this right is denied 

Delete objects* Allows you to delete this 
document. 
NOTE: The Edit objects right 
must also be granted to delete 
a dashboard. 
 

Performance Management: 
Select the Dashboard Manager tab and then the 
Dashboard Builder link. Select this dashboard in 
the Dashboard Structure tree list.  The Remove 
command is disabled and cannot be selected. 
InfoView: In any list containing this document, 
select this document by clicking the check box near 
its name and click the Delete button; an error 
message box appears. 
CMC: In any list containing this document, select 
this document by clicking the check box near its 
name and click the Delete button; an error message 
box appears. 

Define server groups 
to process jobs 

N/A N/A 

Delete instances* N/A N/A 
Copy objects to 
another folder 

Allows you to copy a 
dashboard. If this dashboard 
contains analytics, then the 
copied dashboard contains a 
copy of these analytics. If this 
dashboard references 
analytics located in the CMC, 
the copied dashboard 
references the same analytics. 

CMC: Select the folder containing this document to 
open its panel. Click the Objects tab. Select this 
document and click the Copy/Move/Shortcut… 
button: an error message box appears. 
Performance Management: Select the Dashboard 
Manager tab and then the Dashboard Builder link: 
the Copy link is disabled. 

Schedule to 
destinations 

N/A N/A 

View document 
instances* 

N/A N/A 

Pause and Resume 
document instances* 

N/A N/A 

Securely modify 
rights users have to 
objects* 

See Securely modify rights 
users have to objects, on page 
4. 

See Securely modify rights users have to objects, on 
page 4. 

Reschedule 
instances* 

N/A N/A 

Schedule on behalf of 
other users 

N/A N/A 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

Analytic Rights  
Analytics are graphical components that are used to display value evolution of 
a specific metric in a time scale. Analytic are used to build dashboards. 
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Analytic object can be saved in the CMS or in a dashboard with the difference 
being the folllowing:  

• If it is saved in the CMS, it can be used in different dashboards. As any 
object in the CMS, general rights enforced by the platform apply to this 
analytic. These rights are checked before applying any action to the 
analytic.  

• If it saved in a dashboard, this analytic can be used only on this dashboard 
and no rights are applied to this analytic, except the ones that are applied 
to the dashboard. When applicable, these rights are inherited by the 
analytic. 

General rights related to scheduling are not enforced by analytics.  

General Right Description  Impact if this right is denied 

Add objects to the 
folder 

N/A N/A 

View objects* Allows you to view this 
analytic. 

See View Objects Right, on page 6. 

Edit objects* Allows you to modify this 
analytic content and its 
properties (name, description, 
categories…).  
See Edit Objects Right on 
page 7. 

InfoView: In any list containing this analytic, click 
this analytic’s Properties link. The Properties page 
appears for this analytic but the content is disabled. 

CMC: Select this analytic to open its panel. 

• Click the Properties tab and its content is 
disabled (input fields cannot be edited and the 
Update and Reset buttons are disabled).  

• Click the Process tab and its content is disabled 
(input fields cannot be edited and the Update 
and Reset buttons are disabled).  

• Click the Categories tab; the Assign Category 
button is disabled. 

Modify the rights 
users have to objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Schedule the 
document to run 

N/A N/A 

Delete objects* Allows you to delete this 
analytic. 

InfoView: In any list containing this analytic, select 
this analytic by clicking the check box near its name 
and click the Delete button; an error message box 
appears. 

CMC: In any list containing this analytic, select this 
analytic by clicking the check box near its name and 
click the Delete button; an error message box 
appears. 

Define server groups 
to process jobs 

N/A N/A 

Delete instances* N/A N/A 
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General Right Description  Impact if this right is denied 

Copy objects to 
another folder 

Allows you to create a copy 
of this analytic in the CMS. 

InfoView: In any list containing this analytic, select 
this analytic by clicking the check box near its name. 
On the Organize menu, select the Copy to New 
Folder… command. Select a destination folder and 
click the OK button; an error message is displayed. 
CMC: Select the folder containing this analytic to 
open its panel. Click the Objects tab. Select this 
document and click the Copy/Move/Shortcut… 
button; an error message box appears. 

Schedule to 
destinations 

N/A N/A 

View document 
instances* 

N/A N/A 

Pause and Resume 
document instances* 

N/A N/A 

Securely modify 
rights users have to 
objects* 

See Securely modify rights 
users have to objects, on page 
4. 

See Securely modify rights users have to objects, on 
page 4. 

Reschedule 
instances* 

N/A N/A 

Schedule on behalf of 
other users 

N/A N/A 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

Program Rights 
A program object is an object in BusinessObjects Enterprise that represents an 
application. Once saved in the CMS, BusinessObjects Enterprise can schedule 
and run the program object and manage user rights in relation to it. For more 
information program objects, see the BusinessObjects Enterprise XI Release 2 
Administrator’s Guide. 

General Right Description  Impact if this right is denied 

Add objects to the 
folder 

N/A N/A 

View objects* Allows you to view this 
object. 

See View Objects Right, on page 6. 
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General Right Description  Impact if this right is denied 

Edit objects* Allows you to modify this 
program content and its 
properties (name, description, 
categories…).  
See Edit Objects Right on 
page 7. 

InfoView: In any list containing this program, click 
this program’s Properties link. The Properties page 
appears for this program but its content is disabled. 

CMC: Select this program to open its panel. 

• Click the Properties tab and its content is 
disabled (input fields cannot be edited and the 
Update and Reset buttons are unavailable). 
Click the Process tab and its content is disabled 
(input fields cannot be edited and the Update 
and Reset buttons are unavailable).  

• Click the Categories tab; the Assign Category 
button is disabled. 

Modify the rights 
users have to objects* 

See  Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Schedule the 
document to run 

Allows you to run and 
schedule this program. 

InfoView: In any list containing this program, the 
Schedule link is not displayed for this program. 

CMC: Select this program to open its panel. Click 
the Schedule tab; the Schedule button is disabled. 

Delete objects* Allows you to delete this 
program. 

InfoView: In any list containing this program, select 
this program by clicking the check box near its 
name and click the Delete button; an error message 
box appears. 

CMC: In any list containing this program, select this 
program by clicking the check box near its name 
and click the Delete button; an error message box 
appears. 

Define server groups 
to process jobs 

Allows you to define process 
group to use to process this 
program schedule. The Edit 
objects right must also be 
granted. 

InfoView: In any list containing this program, click 
this program’s Schedule link. The Schedule page 
appears for this program. Modify the parameters 
under the Server Group section and click the 
Update button; an error message is displayed. 

CMC: Select this program to open its panel. Click 
the Process tab; its content is disabled (input fields 
cannot be edited and the Update and Reset buttons 
are unavailable).   

Delete instances* Allows you to delete this 
document’s instances. 

InfoView: In any list containing this program, click 
this program’s History link. The list of instances for 
this program is displayed. Select some instances by 
clicking the check box near their names and click the 
Delete button;  an error message is displayed. 

CMC: Select this program to open its panel. Click 
the History tab. Select some instances and click the 
Delete button; an error message box appears. 
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General Right Description  Impact if this right is denied 

Copy objects to 
another folder 

Allows you to create a copy 
of this document in another 
folder in the CMS. 

Interactive Viewer: The Document > Save as menu 
is not displayed. 
InfoView: In any list containing this document, 
select this document by clicking the check box near 
its name. On the Organize menu, select the Copy to 
New Folder… command. Select a destination folder 
and click the OK button; an error message is 
displayed. 
CMC: Select the folder containing this document to 
open its panel. Click the Objects tab. Select this 
document and click the Copy/Move/Shortcut… 
button; an error message box appears. 

Schedule to 
destinations 

Allows you to change this 
program’s schedule 
destinations (Default, Email, 
Inbox).  

The following rights must 
also be granted:  

• Schedule the document 
to run at program level 

• Add objects to the folder 
for the recipient inbox 
folders if the destinations 
contain inboxes.  

InfoView: In any list containing this program, click 
this document’s Schedule link. The Schedule page 
appears for this program: the Destination section is 
not displayed. 
CMC: Select this program to open its panel. Click 
the Schedule tab, then the Destination sub-tab and 
its content is disabled (input fields cannot be edited 
and the Update and Reset buttons are unavailable). 

 

View document 
instances* 

Allows you to view the 
instances of this document. 

InfoView: In any list containing this document, the 
History link is not displayed for this document. 
CMC: Select this document to open its panel. Click 
the History tab; the list of instances is empty. 

Pause and Resume 
document instances* 

Allows you to pause or 
resume a schedule (even the 
ones that have not been 
created by the user). 
The View document 
instances right must also be 
granted. 

InfoView: In any list containing this program, click 
this program’s History link. The list of instances for 
this program is displayed. Select some instances by 
clicking the check box near their names. Click the 
Pause or Resume button; an error message is 
displayed.  
CMC: Select this program to open its panel. Click 
the History tab. Select some instances and click the 
Pause or Resume button; an error message box 
appears. 

Securely modify 
rights users have to 
objects* 

See  Securely modify rights 
users have to objects , on 
page 4. 

See  Securely modify rights users have to objects , 
on page 4. 
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General Right Description  Impact if this right is denied 

Reschedule 
instances* 

Allows you to reschedule an 
instance of this program.  

The View document 
instances right must also be 
granted. 

InfoView: In any list containing this program, click 
this program’s History link. The list of instances for 
this program is displayed but the Reschedule link is 
not available in the Reschedule column. 
CMC: N/A since it is not possible to reschedule an 
instance in the CMC. 

Schedule on behalf of 
other users 

Allows you to schedule this 
program for another user or 
group. The schedule runs 
with the credential of the 
other user or group who 
becomes the owner of the 
new instance. The result is the 
same as if the other user or 
group schedules the program 
himself.  

The Schedule the document 
to run right must also be 
granted. 

InfoView: N/A. It is not possible to schedule on 
behalf of other users in InfoView. 

CMC: Select this program to open its panel. Click 
the Schedule tab, then the Schedule For sub-tab. 
Change the list of users or groups to schedule this 
program for and click the Update button; an error 
message is displayed. 

 

 

 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5).  

Agnostic Document Rights 
In addition to the BusinessObjects documents, some common file types can be 
stored in the CMS. These documents are called agnostic documents. Before 
BusinessObjects XI Release 2 SP2, the list of possible agnostic documents was: 
DOC, XLS, PDF, RTF, TXT and PPT. These files can be uploaded in the CMS 
through InfoView or the Import Wizard. In BusinessObjects XI Release 2 SP2, 
new agnostic documents are supported: SVG, XML, SWF, CSV, GIF, JPG, BMP 
and PNG. Nevertheless, they can only be uploaded through the Import 
Wizard, in a migration from 5.x/6.x repository. 

In the CMS, these agnostic documents enforce some rights.  

General Right Description  Impact if this right is denied 

Add objects to the 
folder 

N/A N/A 

View objects* Allows you to view this 
object. 

See View Objects Right, on page 6. 
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General Right Description  Impact if this right is denied 

Edit objects* Allows you to edit this 
document: document’s 
properties (name, description, 
categories…) and content. 

InfoView: In the document list, click on the 
document’s Properties link. The Properties page 
appears for this document but its content cannot be 
edited. 
CMC:  
• In the document’s Properties tab: content is 

greyed and cannot be edited; the Update and 
Reset buttons are disabled and cannot be used. 
In the document’s Categories tab, the Assign 
Categories button is grayed and cannot be used. 

Modify the rights 
users have to objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 
4. 

Schedule the 
document to run 

N/A N/A 

Delete objects* Allows you to delete this 
document. 

InfoView: Select this document and click the Delete 
icon: an error message is displayed. 
CMC: Select this document and click the Delete 
button and an error message is displayed. 

Define server groups 
to process jobs 

N/A N/A 

Delete instances* N/A N/A 
Copy objects to 
another folder 

Allows you to create a copy 
of this document in another 
folder in the CMS. 

InfoView: Select the document and then select 
Organize > Copy to New Folder. Select the 
destination folder and click OK: an error message is 
displayed. 
CMC: In the Objects tab of the folder containing the 
document, select the object and click the 
Copy/Move/Shortcut… button; an error message 
box appears. 

Schedule to 
destinations 

N/A N/A 

View document 
instances* 

N/A N/A 

Pause and Resume 
document instances* 

N/A N/A 

Securely modify 
rights users have to 
objects* 

See Securely modify rights 
users have to objects, on page 
4. 

See Securely modify rights users have to objects, on 
page 4. 

Reschedule instances* N/A N/A 
Schedule on behalf of 
other users 

N/A N/A 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 
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Universe and Universe Folder Rights 

Universe Folder Rights  
In the CMS, universes are organized in universe folders. Like other objects in 
the CMS, different rights can be set at a universe folder level:  

• General rights are described in the following table. These rights are basic 
rights enforced by the framework and applicable to the universe folder. 
These rights are also inherited by the object’s universe belonging to this 
folder (see Universe Rights on page 77 for a description of these rights 
when they apply to universes).  

• Universe custom rights, described in Universe Rights on page 77. They do 
not apply to folders but are inherited by all universes objects contained in 
this folder. In the CMC, these rights are displayed under the Universe 
section.  

NOTE Universe folders can be created in the Designer, but not in the CMC. 

 

General Right Description Impact if this right is denied  

Add objects to 
the folder  

Allows you to add a sub-folder or 
a universe in this folder.  

Designer: 
• Select File > Import… or File > Export… In the 

Import Universe or Export Universe panel, click 
the Browse button to navigate in the CMS 
universes hierarchy. Select this folder and click 
the Insert a new folder button; an error message 
box appears. 

• Select File > Export… to export a universe into the 
CMS. The Export Universe panel opens; click the 
Browse button to navigate in the CMS universes 
hierarchy. Select this folder, click the OK button 
to validate this folder, and click the OK button to 
validate the export; an error message box appears. 

CMC: N/A since it is not possible to add a universe 
or a folder with the CMC.  

View objects* Allows you to view this folder. See  View Objects Right, on page 6. 
In Desktop Intelligence and InfoView, universes are 
listed in a flat list: it is not needed to drill into the 
universe folder. Thus, if the View objects right is 
effectively granted for universes belonging to this 
folder (inheritance broken), these universes are 
displayed in the universe list, even if the View objects 
right is denied at folder level. 
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General Right Description Impact if this right is denied  

Edit objects* Allows you to edit this folder’s 
properties in the CMC. 
 

CMC: In this folder’s Properties tab, content is 
disabled and the Update and Reset buttons are 
disabled.  
NOTE: In BusinessObjects XI Release 2, this right 
must also be granted to delete a universe folder in the 
Designer. 

Modify the 
rights users 
have to objects* 

See Modify the rights users have 
to objects, on page 4. 
 

See Modify the rights users have to objects, on page 4. 
CMC: In the folder’s Object Level Security tab, the 
Add/Remove, Update and Reset buttons are disabled. 

Schedule the 
document to 
run  

N/A N/A 

Delete objects* Allows you to delete this folder.  
 

Designer: On the File menu, select the Import… or 
Export… command. In the Import Universe or Export 
Universe panel, click Browse to navigate in the CMS 
universes folders. Select this folder and click the 
Delete icon: an error message box appears. 
NOTE: In BusinessObjects XI Release 2, the Edit 
objects right must also be granted to delete a universe 
folder in the Designer. 
CMC: In the folder list, the check box for this folder is 
disabled and cannot be selected. 

Copy objects to 
another folder     

N/A: it is not possible to copy a 
universe folder in the CMC or in 
Designer. 

N/A 

Securely 
modify rights 
users have to 
objects*    

See  Securely modify rights users 
have to objects, on page 4. 

See  Securely modify rights users have to objects, on 
page 4. 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

Universe Rights 
A universe is a file that contains the following data: 

• Connection parameters for one or more database middleware. 

• SQL structures called objects that map to actual SQL structures in the 
database such as columns, tables, and database functions. Objects are 
grouped into classes. Objects and classes are both visible to Web 
Intelligence and Desktop Intelligence users. 

• A schema of the tables and joins used in the database. Objects are built 
from the database structures that you include in your schema. The schema 
is only available to Designer users. It is not visible to Web Intelligence and 
Desktop Intelligence users. 
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NOTE Universe rights are enforced only when the universe is imported directly by the Designer 
from the CMS. Once the universe is saved locally on the machine, the rights that have 
been set are lost and all actions are granted. 

 
 

General  Right Description Impact if this right is denied 

Add objects to 
the folder 

Allows you to add a restriction 
set to this universe. In this case, 
the universe is seen as a 
container, the restriction set being 
an object to add into the universe. 

The right Edit Access 
Restrictions must also be granted 
in order to add a restriction to a 
universe. 

Designer: Select Tools > Manage Security… > 
Manage Access Restrictions. The Manage Access 
Restrictions window appears. Create a restriction 
and assign it to a user or a group. Click the OK 
button to validate it; an error message box appears. 

View objects* Allows you to view this universe. 
This right impacts all workflows 
where this universe can be used:  

• Create a document based on 
this universe 

• Refresh a document based on 
this universe 

• … 

 

See View Objects Right, on page 6.  

Some examples:  

CMC: This universe is not listed in the universe 
lists. 

InfoView: In the New menu, select the Web 
Intelligence Document command; this universe is 
not displayed in the list. 

Desktop Intelligence:  

• In the New Report Wizard, in the Select a 
Universe step, this universe is not displayed in 
the list of available universes. 

• Import a document based on this universe from 
the repository. Click the Refresh Data or Edit 
Data Provider icons or in the Data menu, select 
the Refresh Data or Data > Edit Data Provider 
command; an error message box appears.  

Desktop Intelligence HTML Viewer: Import a 
document based on this universe from the 
repository: click the Refresh Data button; an error 
message box appears. 

Web Intelligence Interactive Viewer: Refresh a 
document based on this universe; an error message 
box appears.  

Web Intelligence Java Report Panel: Open a 
document based on this universe. Click the Edit 
Query or Run Query button; an error box appears.  

Web Intelligence Query HTML: Open a document 
based on this universe: the Query and Query Filters 
tabs are not displayed.  
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General  Right Description Impact if this right is denied 

Edit objects* Allows you to edit this universe 
through the CMC or the 
Designer. 

This right is also needed to apply 
or remove a universe lock. 

CMC: This universe’s Properties page is disabled: 
input field cannot be edited and the Update and 
Reset buttons cannot be clicked.  

Designer:  

• Import a universe locally from the CMS. Modify 
it and export it to the CMS: if you keep the same 
folder and universe name, an error message is 
displayed since it is not possible to update the 
original universe in the CMS. 

• Select the File > Import… command. The 
Import Universe dialog box appears. Double-
click on a universe locked by another user to 
unlock it: an error message is displayed. 

Modify the rights 
users have to 
objects* 

See Modify the rights users have 
to objects, on page 4. This right 
allows also the user to modify 
this universe Object Level 
Security (see  on page 81). 

• See Modify the rights users have to objects, on 
page 4.  

CMC: In this universe’s Object Level Security 
page, the Add/Remove, Update and Reset buttons 
are disabled. 

Schedule the 
document to run 

N/A N/A 

Delete objects* Allows you to delete this 
universe. 

CMC: In the universe list, the check box near the 
universe’s name is disabled and cannot be selected.  

Designer: N/A (it is not possible to delete a 
universe from Designer). 

Copy objects to 
another folder 

N/A since no application allows 
you to directly copy a universe.  

N/A 

Securely modify 
rights users have 
to objects* 

See Securely modify rights users 
have to objects, on page 4. 

See Securely modify rights users have to objects, on 
page 4. 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5).  
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Custom Right Description Impact in Designer if this right is denied  

New List of 
Values 

Allows you to associate a 
new list of values with an 
object or edit an existing one 

Note that this right does not 
prevent the creation of 
Cascading List of Values. 

• On the Tools menu, click Lists of Values; then Edit a 
List of Values. In the Lists of Values dialog box, select 
an object; the Edit button and the Corporate Data 
(Query Panel) and Personal Data radio buttons are 
disabled. 

• Open a universe; in the Universe pane, select an object; 
on the Edit menu, click Object Properties (alternatively, 
right-click the object and on the contextual menu, click 
Object Properties); in the Edit Properties dialog box, 
select the Properties tab; the following are disabled:  
• The Associate a List of Values check box 

• The List Name text box 

• The Restore Default button 

• The Edit button 

NOTE: Even if this right is denied, the List Name text box, 
Restore Default and Edit buttons are still enabled. This has 
issue has been logged under ADAPT00848147. 

Print Universe Allows you to print this 
universe. 

On the File menu, the following commands are disabled: 

• Page Setup 

• Print Preview 

• Print 

On the Standard toolbar, the Print and Print Preview 
buttons are disabled. 

Show Table or 
Object Values 

Allows you to see the values 
associated with a table or 
object of this universe. 

 

• Open a universe; in the Structure pane: 

• Right-click a table name: on the shortcut menu, the 
Table Values command is disabled. 

• Right-click a column of a table: on the shortcut 
menu, the Column Values command is disabled. 

• Double-click outside a table in the Structure pane or, on 
the Insert menu, select the Tables command. In the 
Table Browser dialog box: 

• Right-click a table; on the shortcut menu, the View 
Table Values command is disabled. 

• Right-click a column of a table; on the shortcut 
menu, the View Column Values command is 
disabled. 

NOTE: This right has no more impact in the Quick Design 
Wizard. Indeed, it is now applicable at universe level. 
During universe creation, the universe does not already 
exist and thus, this right does not apply. 
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Custom Right Description Impact in Designer if this right is denied  

Edit Access 
Restrictions 

 

Allows you to edit access 
restrictions (overloads…) 
for this universe.  

• On the Tools menu, the Manage Security > Manage 
Access Restrictions command is disabled. 

• In the Editing toolbar, the Create, modify or delete, or 
apply access restrictions button is disabled. 

Unlock 
Universe 

Allows you to unlock this 
universe if it has been 
locked by another user. 
Once unlocked, users can 
then export their own 
version of the universe in 
the CMS. The Edit objects 
right is also needed to 
unlock a universe. 

Select the File > Import… command. The Import Universe 
dialog box appears. Double-click the name of a universe 
locked by another user to unlock it; an error message is 
displayed.  

Data Access Allows you to retrieve data 
returned by this universe 
when refreshing a report.  
In practice, this right grants 
the two following actions: 
• Create a document 

based on this universe 
• Refresh a document 

based on this universe 
(if rights at application, 
document and 
connection level are also 
granted). 

From rights perspective, it is 
not possible to differentiate 
these two actions. 

Designer: No impact. For example, it is still possible to view 
table values even if this right is denied. On the contrary, 
denying a connection’s Data Access right prevents the user 
from retrieving data from the database (see Connection 
Rights on page 82). 
Web Intelligence/Desktop Intelligence: Refresh a 
document based on this universe: an error message is 
displayed (you have no right to access data returned by this 
universe). 

 

Universe Object Security Level 
Designer allows Administrators to set Universe Security Access Level. The 
possible values for the Security Access Level are: Public, Controlled, Restricted, 
Confidential and Private. 

In the CMC, Administrators can then define which objects a user will be 
allowed to see by setting Object Security Level for universes and users. Public 
is the most restrictive value and means that the user will see only objects that 
are Public. Private is the less restrictive security level since it Allows you to see 
all objects from Public to Private.  

To modify Universe Security Access Level in the CMC, Administrators need to 
have the Modify the rights users have to objects right granted. 

This Object Security Level follows the same framework than ACLs: 
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• It is a relationship between a universe a principal (user or group).  

• A security level set at a universe folder level is inherited by all universes in 
this folder. 

• A right can be set to an individual object to override an inherited right but 
it cannot give more rights, except by breaking inheritance. 

• In aggregation rules, the most restrictive security level wins over the less 
restrictive. 

Connection Rights  
A connection is a named set of parameters that defines how a Business Objects 
application accesses data in a database file. A connection links Business Objects 
products to the middleware and is needed to access data, create a universe, 
refresh reports...  

Connections are created in the Designer. Two types of connections exist:  

• Secured connections that secure access to data. Only these connections can 
be saved in the CMS. They are needed to distribute universes through the 
CMS. 

• Shared connections that allow access to data for all users. 

In the CMS, secured connections are saved as any other objects and benefit 
from the rights generic framework. The connections rights apply only to 
secured connection.   

For more details on connections, see the BusinessObjects Enterprise XI Release 
2 Designer’s Guide. 

General 
Right  Description Impact if this right is denied 

Add objects 
to the 
folder 

N/A N/A 

View 
objects* 

Allows you to view this 
connection. If this right is 
Denied, any object that relies 
on this connection is not 
allowed to access the database. 

See  View Objects Right, on page 6. In addition, in any 
application, any workflow that needs access to the database 
referred by this connection fails. For example:  

Web Intelligence: Refresh a document based on a universe 
based on this connection; an error message box appears. 

Desktop Intelligence: Refresh a document based on a 
universe based on this connection; an error message box 
appears. 

Designer: When creating or modifying a universe (in the 
Quick Design Wizard or in the Universe Parameters 
panel), this connection does not appear in the list of 
available connections.  
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General 
Right  Description Impact if this right is denied 

Edit 
objects* 

Allows you to modify this 
connection properties (name 
and description). 

 

CMC:  

• In the connection’s Properties tab, content is disabled; 
the Update and Reset buttons are disabled.  

• In the connection list, the check box near the connection 
name is unavailable and cannot be selected. 

Designer: Select the Tools > Connections… command or 
click the Connections icon in the toolbar. The Wizard 
Connection window is displayed. Select this connection; the 
Edit… button is disabled. 

Modify the 
rights users 
have to 
objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 4. 

Schedule 
the 
document 
to run 

N/A N/A 

Delete 
objects* 

Allows you to delete this 
connection. 

CMC: In the connection list, the check box near the 
connection name is disabled and cannot be selected.  

Designer: Select the Tools > Connections… command or 
click the Connections icon in the toolbar. The Wizard 
Connection window is displayed. Select this connection: the 
Remove button is disabled. 

Copy 
objects to 
another 
folder 

N/A N/A 

Securely 
modify 
rights users 
have to 
objects. * 

See Securely modify rights 
users have to objects, on page 4. 

See Securely modify rights users have to objects, on page 4. 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 
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Custom 
Right Description Impact if this right is denied 

Data 
Access 

Allows you to retrieve data 
from the database defined in 
this connection. 

In Designer, if this right is 
denied, it prevents the user 
from retrieving any 
information from the database: 
database schema or data. 

Web Intelligence: Refresh a document based on a universe 
based on this connection; an error message is displayed. 

Desktop Intelligence: Any workflow that needs access to 
the database or a universe based on this connection fails. 

• In the New Report Wizard, select a universe based on 
this connection; an error message is displayed. 

• Refresh a document based on a universe based on this 
connection; an error message is displayed.  

• Click the Insert Table (or Insert Crosstab, or Insert 
Chart) button on the Report toolbar, or select the Table 
(or Crosstab, or Chart) command on the Insert menu. 
Click in the report to point out the new item location. In 
the New Table wizard (or New Crosstab or New Chart 
wizard), select the Access New Data in a different way 
radio button, click the Begin button. Select the Universe 
radio button, click the Next button. Select a universe 
based on this connection, click the Finish button; an 
error message is displayed. 

Designer: Any workflow that needs access to the database 
fails. For example:  

• Import a universe from the repository. A success 
message box appears.  After this message, another error 
message box appears stating “The universe connection 
is not available”.  

• Right-click on a table and select Table Values…; an 
error message is displayed. 

• On the Insert menu, select the Tables… command; an 
error message box appears. 

Use 
connection 
for Stored 
Procedures 

 

 

Allows you to use the stored 
procedures saved in the 
database referred by this 
connection. The connection 
must be a secured connection 
saved in the repository. 

 

Desktop Intelligence:  

• Create a document from a stored procedure: the 
connection is not displayed in the list of available 
connections. 

• Refresh a document based on a stored procedure saved 
in the database associated to this connection; an error 
message is displayed.  

 

Server Rights 
In BusinessObjectsXI Release 2, servers like the Desktop Intelligence Server, 
Job Server, and CMS are stored in the CMS as InfoObjects; which provide the 
same generic InfoObject framework. These servers are administered in the 
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CMC, where administrators can stop, start, enable them, edit their parameters 
and modify their rights.  

These rights have no impact on the Central Configuration Manager, since no 
authentication is requested to log into it. 

General 
Right Description Impact if this right is denied 

Add objects 
to the folder 

N/A N/A 

View objects* Allows you: 
• to benefit of the services 

provided by this server 
• to view this server in the 

CMC.  

Any workflow involving this server will not terminate 
properly as you will not be able to access this server. 
CMC: In the Home > Servers page, this server name is not 
displayed. 

Edit objects* Allows you to modify: 
• this server properties 

(name, description, 
parameters…) 

• its status (started, 
stopped, enabled, 
disabled) 

• The Group Servers it 
belongs 

CMC:  
• In the parameters tab in this server page, all content is 

disabled and cannot be modified. Depending on the 
servers, these tabs are: Properties, Destinations, 
Auditing or Single Sign-On. The Rights tab is not 
impacted by this right.  

• In the Home > Servers page, select this server by 
clicking the check box near its name. Click the Start, 
Stop, Enable, Disable or Restart button; an error 
message is displayed. 

• In a Group Server page, click the Servers tab, then the 
Add/Remove Servers button. In the Add/Remove 
Servers page, move this server from one list to another, 
then click the OK button; an error message is displayed. 

Modify the 
rights users 
have to 
objects* 

See Modify the rights users 
have to objects, on page 4. 

See Modify the rights users have to objects, on page 4. 

Delete 
objects* 

Allows you to delete this 
server. 

CMC: In the Home > Servers page, select the check box near 
this server name, then click the Delete button; an error 
message is displayed.  

Copy objects 
to another 
folder 

N/A N/A 

Securely 
modify rights 
users have to 
objects. * 

See  Securely modify rights 
users have to objects, on page 
4. 

See  Securely modify rights users have to objects, on page 4. 

*: This right exists also in owner version (see Non-Owner and Owner Version 
of Rights, on page 5). 

11/14/2007 9:26 AM Copyright © 2007 Business Objects. All rights reserved. Page 85 
 

boe_xi_r2_sp2_cmc_rights_descriptions_and_impact_on_applications.pdf 



BusinessObjects Enterprise XI Release 2 SP2 CMC Rights Descriptions and Their Impact on Different Applications 

Rights to Grant to Run Basic Actions  
One of the strengths of the BusinessObjects XI Release 2 security model is its 
granularity. Security can be set at different levels to meet different levels of 
security requirements. The drawback of this flexibility is the number of rights 
to set at different levels to grant one particular action.  The following sections 
describe these rights for some common actions. They do not list rights at server 
object level, since it is not common to disable their rights. Nevertheless, in case 
security is set at server level, the View objects right must be set for the servers 
involved in the granted actions: Web Intelligence Job Server or Desktop 
Intelligence Job Server for scheduling, File Repository Input Server or File 
Repository Output Server to access the repository… 

View a Document 
To view a document, the following rights must be granted: 

• Log on to <application name> and view this object in the CMC right for 
Web Intelligence, Desktop Intelligence or InfoView applications, 
depending on the document type 

• View objects right for the document 

• View objects right for the folder containing the document. Nevertheless, 
this right is not needed, if inheritance between this folder and the 
document has been broken and if the user is able to directly open the 
document without having to access this folder. 

Create a Web Intelligence Document  
To create a Web Intelligence document on a universe, the following rights 
must be granted: 

• Log on to <application name> and view this object in the CMC right for 
Web Intelligence and InfoView applications 

• Create document right for Web Intelligence application 

• View objects and Data Access rights for the universe 

• View objects and Data Access rights for the connection used by the 
universe 

NOTE In InfoView, all universes are displayed in a flat list, without having to drill into the universe 
folder tree. Thus, if the “View objects” right for the universe is effectively granted, it is not 
needed to grant the “View objects” right for the universe folder containing this universe.  

 

Create a Desktop Intelligence Document  
To create a Desktop Intelligence document, the following rights must be 
granted: 
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• Log on to <application name>  and view this object in the CMC right for 
Desktop Intelligence application.  

• Log on to <application name>  and view this object in the CMC right for 
InfoView application, if you create this document through HTTP mode 

• Create document and Use Queries rights for Desktop Intelligence 
application 

If the document is created from a universe, the following rights must also be 
granted: 

• View objects and Data Access rights for the universe 

• View objects and Data Access rights for the connection used by this 
universe 

NOTE In InfoView, all universes are displayed in a flat list, without having to drill into the universe 
folder tree. Thus, if the View objects right for the universe is effectively granted, it is not 
needed to grant the View objects right for the universe folder containing this universe. 

 

If the Data Provider is not a universe, then the rights to grant depend on the 
data provider: 

• If this data provider is a Stored Procedure then View objects, Data Access 
and Use connection for Stored Procedures rights for the corresponding 
connection and the Use Stored Procedures right for Desktop Intelligence 
application. 

• If this data provider is a Personal Data Provider then Use Personal Data 
Files and Edit Personal Data Files rights for Desktop Intelligence 
application. 

Save a Web Intelligence document  
To save a Web Intelligence document in the CMS, one of these rights must be 
granted: 

• Edit objects right for the document, if this action simply updates a 
document that already exists  

• Add object to the folder right for the folder where the document will be 
saved, if this creates a new document in this folder  

• Copy objects to another folder right for the document if a new version of 
an existing file will be saved 

At application level, Web Intelligence does not propose any right to prevent 
users from saving document. A workaround is to disable the Add objects right 
for each folder or disable it at the folder root level and make sure it is inherited 
by all folders. Thus, the Save button is displayed in Web Intelligence, but no 
folder is displayed in the folder list and the user cannot save reports. 
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Save a Desktop Intelligence Document  
To save a Desktop Intelligence document in the CMS, the following rights 
must be granted: 

• Edit objects right for the document, if this action simply updates a 
document that already exists  

• Add object to the folder right for the folder where the document will be 
saved, if this creates a new document in this folder  

•  Send Documents to Repository right for Desktop Intelligence application 

To save a Desktop Intelligence document locally, the following right must be 
granted: 

• Save Desktop Intelligence Documents right for Desktop Intelligence 
application 

• Save documents for all users right for Desktop Intelligence application, to 
save the document without security and allow all users to open it. 

Refresh a Web Intelligence Document 
To refresh a Web Intelligence document based on a universe and a connection, 
the following rights must be granted: 

• Log on to <application name> and view this object in the CMC right for 
Web Intelligence and InfoView applications 

• View objects and Refresh the report's data rights for the document 

• View objects right for the folder containing the document. Nevertheless, 
this right is not needed, if inheritance between this folder and the 
document has been broken and if the user is able to directly open the 
document without having to access this folder. 

• “View objects” and “Data Access” rights for the universe 

• “View objects” and “Data Access” rights for the connection. 

Refresh a Desktop Intelligence Document 
To refresh a Desktop Intelligence document stored on the CMS and based on a 
universe, the following rights must be granted: 

• Log on to <application name> and view this object in the CMC rights for 
Desktop Intelligence and InfoView applications  

• Refresh Desktop Intelligence Document right for Desktop Intelligence 

• View objects and Refresh the report's data rights for the document 

• View objects right for the folder containing the document. Nevertheless, 
this right is not needed, if inheritance between this folder and the 
document has been broken and if the user is able to directly open the 
document without having to access this folder. 
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If the data provider is a universe, the following rights must also be granted: 

• View objects and Data Access rights for the universe 

• View objects and Data Access rights for the connection. 

If the data provider is a stored procedure, then the rights to grant are: 

• View objects, Data Access and Use connection for Stored Procedures 
rights for the connections used by the universe and referring the database 
containing the stored procedure 

• Use Stored Procedures right for Desktop Intelligence application. 

If the data provider is a Personal Data Provider, then no other right is required 
(the Use Personal Data Files right for the Desktop Intelligence application is 
not needed). 

Edit a Document 
To edit a Web Intelligence or a Desktop Intelligence document, the following 
rights must be granted: 

• Log on to <application name> and view this object in the CMC rights for 
Web Intelligence, Desktop Intelligence or InfoView, depending on the 
document type 

• View objects and Edit objects rights for the document 

• View objects right for the folder containing the document. Nevertheless, 
this right is not needed if inheritance between this folder and the 
document has been broken and if the user is able to directly open the 
document without having to access this folder. 

If the data provider is a universe, the following rights must also be granted: 

• View objects and Data Access rights for the universe 

• View objects and Data Access rights for the connection. 

If the data provider is a Personal Data Provider, then the Edit Personal Data 
Files right for the Desktop Intelligence application is not needed. Unless a 
change in the structure of the personal data file used or in the parameters to 
use it needs to edit how this personal data file is accessed.  

Move a Category into Another Category  
To move a category into a destination category, the following rights must be 
granted: 

• View objects, Edit objects and Delete objects rights for the category to 
move 

• View objects, Add objects to the folder rights for the destination category. 
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Add a Document into a Category 
To move a document into a category, the following rights must be granted: 

• View objects, Add objects to the folder rights for the category 

• View objects, Edit objects rights for the document. 

Schedule a Document 
In BusinessObjects XI Release 2, scheduling is a feature enforced by the 
framework and scheduling rights are General rights. So for all applications that 
use this scheduling framework (Web Intelligence, Desktop Intelligence, Crystal 
Reports but not Performance Management) the following rights must be 
granted to schedule a document:  

• Log on to <application name> and view this object in the CMC rights for 
CMC or InfoView, depending on the application where the schedule is 
created 

• View objects right for the document 

• Schedule the document to run right for the document 

• And the same universe and connection rights needed to refresh the 
document (see Refresh a Web Intelligence document and Refresh a 
Desktop Intelligence document on page 88). 

The document is refreshed when it is scheduled, nevertheless: 

• The Refresh right is not needed at document level (for a Web Intelligence, 
Desktop Intelligence or Crystal Reports document) 

• But the Refresh Desktop Intelligence Document right must be granted at 
Desktop Intelligence application level to schedule a Desktop Intelligence 
document. 

Some additional rights must also be granted to change some schedule 
parameters:   

• Schedule to destinations right for the document, to change the schedule 
default destination  

• Add objects to Folder and View objects rights for the destination Inbox 
folder, if the destination is an Inbox folder 

• Define server groups to process jobs right to change the server groups 
that will process the schedule. 

To manage scheduling, some General rights can also be useful at document 
level: Define server groups to process jobs, Delete instances, View document 
instances, Pause and Resume document instances, Reschedule instances and 
Schedule on behalf of other users. 

Send a Document in Inbox 
Any files stored in the CMS, even the agnostic ones, can be sent to a user’s 
Inbox. The file is sent as is, without any refresh in the case of Web Intelligence 

11/14/2007 9:26 AM Copyright © 2007 Business Objects. All rights reserved. Page 90 
 

boe_xi_r2_sp2_cmc_rights_descriptions_and_impact_on_applications.pdf 



BusinessObjects Enterprise XI Release 2 SP2 CMC Rights Descriptions and Their Impact on Different Applications 

or Desktop Intelligence file. To send a document to a user’s Inbox, the 
following rights must be granted:  

• Send document right for InfoView application, if the document is sent 
from InfoView 

• Add objects to Folder and View objects rights for the destination Inbox 
folder 

Add a User or a Group into Another Group 
To add a user or a group into a destination group, the following rights must be 
granted:  

• View objects, Edit objects rights for the destination group 

• View objects, Edit objects rights for the source user or group 

Finding more information 
For more information and resources, refer to the product documentation and 
visit the support area of the web site at: http://www.businessobjects.com/
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